HDU 1004 let the balloon rise(map,STL和非map)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 146133    Accepted Submission(s): 57994


 

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

 

 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

 

 

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

 

 

Sample Input

 

5 green red blue red red 3 pink orange pink 0

 

 

Sample Output

 

red pink

题意:输出出现次数最多的字符串

刚开始学习STL,有些基础的知识在代码中标记一下

map<string,int>m: 建立一个名称为m的容器,map就是一个一对一的key,value对,使用key来快速寻找其value值,m[key]=value,key的类型就是string,value的类型就是int。

map<string,int>::iterator it :建立一个名称为it的迭代器,迭代器的类型是iterator ,m.begin()表示map的开头,

it->frist表示对象的第一个类型,一般是key.
it->second表示对象的第二个类型,一般是value

 mapAC代码

#include<iostream>
#include<cstdio> 
#include<cstring>
#include<map>
using namespace std;
string s[1005],ss;
map<string,int>m;

int main()
{
	int i,j,k,n;

	while(scanf("%d",&n)&&n)
	{
		int max=0;
		m.clear();
		for(i=1;i<=n;i++)
		{
		
		cin>>s[i];
		m[s[i]]++;
		}

	for(map<string,int>::iterator it=m.begin();it!=m.end();it++)
	{
		if(it->second>max) //选取一个value最大的
		{
			max=it->second;
			ss=it->first; 
		}
	}
	cout<<ss<<endl;
	}	
	return 0;
}

此题也可以不用map,用了一个strcmp()函数,AC代码

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int f[1005];
char a[1005][20];
int main()
{
	int n;
	
	int i,j;
	while(scanf("%d",&n)&&n)
{
    memset(f,0,sizeof(f));
    int min=1;
	for(i=1;i<=n;i++)
	{
	  scanf("%s",&a[i]);
	  for(j=1;j<i;j++)
	  {
	  	if(strcmp(a[j],a[i])==0){
		  
		  f[j]++;
		  break;
	}
		  }	
	}
	for(i=1;i<=n;i++)
	{
		if(f[i]>f[min])
		{
			min=i;
		}
	}
	
	printf("%s\n",a[min]);
}
	return 0;
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值