hdu 1002 大数加法

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 438052    Accepted Submission(s): 85245


 

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

 

 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

 

 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

 

 

Sample Input

 

2 1 2 112233445566778899 998877665544332211

 

 

Sample Output

 

Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110

思路很唯一,就是用字符串存储这个大数

AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
using namespace std;
int main()
{
	char op1[1002],op2[1002];
	int num[1002],num1[1002],num2[1002];
	int n,i,j,k,m;
	scanf("%d",&n);
	for(k=1;k<=n;k++)
	{
		memset(num,0,sizeof(num));
		memset(num1,0,sizeof(num1));
		memset(num2,0,sizeof(num2));
		scanf("%s%s",&op1,&op2);
		int len1=strlen(op1);
		int len2=strlen(op2);
	//	cout<<len1<<len2<<endl;
		for(i=len1-1;i>=0;i--)
		{
			num1[len1-1-i]=op1[i]-'0';
		//	cout<<num1[i];
		}
		for(i=len2-1;i>=0;i--)
		{
			num2[len2-1-i]=op2[i]-'0';
		}
		m=len1>len2?len1:len2;
	//	cout<<m<<endl;
		for(i=0;i<m;i++)
		{
			if(num1[i]+num2[i]+num[i]>=10)
			{
				num[i]=num[i]+num1[i]+num2[i]-10;
				num[i+1]++;
			}
			else num[i]+=num1[i]+num2[i];
		}
	printf("Case %d:\n",k);
	printf("%s + %s = ",op1,op2);
		for(i=m+1-1;i>0;i--)
		if(num[i]) break;
	//	cout<<i<<endl;
		for(j=i;j>=0;j--) cout<<num[j];
		cout<<endl;
		if(k!=n) cout<<endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
大学生就业服务平台管理系统按照操作主体分为管理员和用户。管理员的功能包括学生档案管理、字典管理、试卷管理、试卷选题管理、试题表管理、考试记录表管理、答题详情表管理、错题表管理、法律法规管理、法律法规收藏管理、法律法规留言管理、就业分析管理、论坛管理、企业管理、简历管理、老师管理、简历投递管理、新闻资讯管理、新闻资讯收藏管理、新闻资讯留言管理、学生信息管理、宣传管理、学生管理、职位招聘管理、职位收藏管理、招聘咨询管理、管理员管理。用户的功能等。该系统采用了Mysql数据库,Java语言,Spring Boot框架等技术进行编程实现。 大学生就业服务平台管理系统可以提高大学生就业服务平台信息管理问题的解决效率,优化大学生就业服务平台信息处理流程,保证大学生就业服务平台信息数据的安全,它是一个非常可靠,非常安全的应用程序。 管理员权限操作的功能包括管理新闻信息,管理大学生就业服务平台信息,包括考试管理,培训管理,投递管理,薪资管理等,可以管理新闻信息。 考试管理界面,管理员在考试管理界面中可以对界面中显示,可以对考试信息的考试状态进行查看,可以添加新的考试信息等。投递管理界面,管理员在投递管理界面中查看投递种类信息,投递描述信息,新增投递信息等。新闻信息管理界面,管理员在新闻信息管理界面中新增新闻信息,可以删除新闻信息。新闻信息类型管理界面,管理员在新闻信息类型管理界面查看新闻信息的工作状态,可以对新闻信息的数据进行导出,可以添加新新闻信息的信息,可以编辑新闻信息信息,删除新闻信息信息。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值