HDU 4595 Shaolin (c++ map)

 

Problem Description

Shaolin temple is very famous for its Kongfu monks.A lot of young men go to Shaolin temple every year, trying to be a monk there. The master of Shaolin evaluates a young man mainly by his talent on understanding the Buddism scripture, but fighting skill is also taken into account.
When a young man passes all the tests and is declared a new monk of Shaolin, there will be a fight , as a part of the welcome party. Every monk has an unique id and a unique fighting grade, which are all integers. The new monk must fight with a old monk whose fighting grade is closest to his fighting grade. If there are two old monks satisfying that condition, the new monk will take the one whose fighting grade is less than his.
The master is the first monk in Shaolin, his id is 1,and his fighting grade is 1,000,000,000.He just lost the fighting records. But he still remembers who joined Shaolin earlier, who joined later. Please recover the fighting records for him.

 

 

Input

There are several test cases.
In each test case:
The first line is a integer n (0 <n <=100,000),meaning the number of monks who joined Shaolin after the master did.(The master is not included).Then n lines follow. Each line has two integer k and g, meaning a monk's id and his fighting grade.( 0<= k ,g<=5,000,000)
The monks are listed by ascending order of jointing time.In other words, monks who joined Shaolin earlier come first.
The input ends with n = 0.

 

 

Output

A fight can be described as two ids of the monks who make that fight. For each test case, output all fights by the ascending order of happening time. Each fight in a line. For each fight, print the new monk's id first ,then the old monk's id.

 

 

Sample Input

 

3 2 1 3 3 4 2 0

 

 

Sample Output

 

2 1 3 2 4 2

 题意:先输入一个n,接下来有n行,每行输入盲僧的代号和战力,且代号都是升序给出的,每输入一行,就代表这个盲僧要加入,当前加入的盲僧就要和在他之前加入的且战力和他差值最小的盲僧solo一次,如果存在两个盲僧和他的差值相同,他就选择比自己弱的那个盲僧solo。最后要你输出当前要加入的盲僧的id以及和他solo的老盲僧的id。

思路:就是STL中Map的使用,

map查找时需要记录一个key值,即map[key] = value,这里我们把key值设为盲僧的战斗力,把id设为value,也就是

map[grade] = id,存入map中,它会自动按照key的值排序。再用上STL的迭代器,基本就能解决这个问题了

 

 

 AC代码:

#include<iostream>
#include<cstdio>
#include<map>
#include<cmath>
using namespace std;
int main()
{
	int n;
	map<int,int> m;
	while(~scanf("%d",&n)&&n)
	{
		int i;
		int ans=0;
		m[1000000000]=1;
		int id,grade;
		for(i=1;i<=n;i++)
		{		
		scanf("%d%d",&id,&grade);
		m[grade]=id;
		map<int,int> ::iterator temp; //定义temp为iterator类的一个对象,也就是map容器上的迭代器 
		temp=m.find(grade); 
		if(temp==m.begin()) //如果当前的战力是最低的,那就只能打比他战力高的那一个
		{
			ans=(++temp)->second; 
		}
		else 
		{
			map<int,int> ::iterator temp2=temp;
			if(abs((++temp)->first - grade)>=abs((--temp2)->first - grade))
			{
				ans=temp2->second;
			}
			else ans=temp->second;
		}
		
            printf("%d %d\n", id , ans);
	}
		m.clear();   //这步不要忘了,因为在一个程序中要输入多次n 
		}
	return 0;
 } 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值