POJ 3687 Labeling Balls(拓扑排序【反向建图+优先队列】)

Labeling Balls
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12426 Accepted: 3570

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4


题意:有n个小球,给出m个约束条件,A  B 表示编号为A的球比编号为B的球轻。求输出编号从1到n升序的每个球的重量是第几轻。


求法略坑,先用拓扑把按重量关系把球编号排序,再转化为编号对应的球的轻量排名值。


具体代码如下:


#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
int n,indegree[210];
int map[210][210];
int num[210],ans[210];

void topo()
{
	int i,k=1,top;
	priority_queue<int>q;//按降序排列 
	for(i=1;i<=n;++i)
	{
		if(indegree[i]==0)
		   q.push(i);
	}
	while(!q.empty())
	{
		top=q.top();
		q.pop();
		num[k++]=top;//这里是按轻量排序的小球编号,且是逆序的 
		for(i=1;i<=n;++i)
		{
			if(map[top][i])
			{
				indegree[i]--;
				if(indegree[i]==0)
				   q.push(i);
			}
		}
	}
	if(k==n+1)//利用k值判断是否存在环 
	{
		for(i=1;i<=n;++i)
			ans[num[i]]=n+1-i;//转化为顺序的编号升序的小球重量排序 
		for(i=1;i<n;++i)
		   printf("%d ",ans[i]);
		printf("%d\n",ans[n]);
	}
	else
	   printf("-1\n");
}

int main()
{
	int m,i,a,b,t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		memset(map,0,sizeof(map));
		memset(indegree,0,sizeof(indegree));
		while(m--)
		{
			scanf("%d%d",&a,&b);
			if(map[b][a]==0)//逆向建图 
		    {
		    	map[b][a]=1;
		    	indegree[a]++;
		    }
		}
		topo();
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值