HDOJ 5240 Exam(水)

Exam

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1031    Accepted Submission(s): 513


Problem Description
As this term is going to end, DRD needs to prepare for his final exams.

DRD has
n exams. They are all hard, but their difficulties are different. DRD will spend at least ri hours on the i -th course before its exam starts, or he will fail it. The i -th course's exam will take place ei hours later from now, and it will last for li hours. When DRD takes an exam, he must devote himself to this exam and cannot (p)review any courses. Note that DRD can review for discontinuous time.

So he wonder whether he can pass all of his courses.

No two exams will collide.
 

Input
First line: an positive integer T20 indicating the number of test cases.
There are T cases following. In each case, the first line contains an positive integer
n105 , and n lines follow. In each of these lines, there are 3 integers ri,ei,li , where 0ri,ei,li109 .

 

Output
For each test case: output ''Case #x: ans'' (without quotes), where x is the number of test cases, and ans is ''YES'' (without quotes) if DRD can pass all the courses, and otherwise ''NO'' (without quotes).

 

Sample Input
  
  
2 3 3 2 2 5 100 2 7 1000 2 3 3 10 2 5 100 2 7 1000 2
 

Sample Output
  
  
Case #1: NO Case #2: YES
 

 

题意:有n课要考试了,接下来n行每行有三个数字r,e,l。r表示当前这门课需要复习的时间,e表示从现在开始距离 当前这门课考试还有多长时间,l表示当前这门课的上课时间。问着n门课是否都能复习并完成考试。

很水的题,不过要注意给这些科目按照考试先后排序,数据不一定是升序。这个地方wa了三发,实在可惜。

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
    int t,e,l;
}num[100010];

int cmp(node a,node b)
{
    return a.e<b.e;
}

int main()
{
    int T,i,e,n,k=1;
    __int64 t,l;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(i=0;i<n;++i)
            scanf("%d%d%d",&num[i].t,&num[i].e,&num[i].l);
        sort(num,num+n,cmp);
        int sign=1,time=0;
        for(i=0;i<n;++i)
        {
            time+=num[i].t;
            if(time>num[i].e)
            {
                sign=0;
                break;
            }
            time+=num[i].l;
        }
        if(sign)
            printf("Case #%d: YES\n",k++);
        else
            printf("Case #%d: NO\n",k++);
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值