HDOJ 5240 Exam 【简单模拟】

Exam

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1041    Accepted Submission(s): 521


Problem Description
As this term is going to end, DRD needs to prepare for his final exams.

DRD has n exams. They are all hard, but their difficulties are different. DRD will spend at least ri hours on the i -th course before its exam starts, or he will fail it. The i -th course's exam will take place ei hours later from now, and it will last for li hours. When DRD takes an exam, he must devote himself to this exam and cannot (p)review any courses. Note that DRD can review for discontinuous time.

So he wonder whether he can pass all of his courses.

No two exams will collide.
 


Input
First line: an positive integer T20 indicating the number of test cases.
There are T cases following. In each case, the first line contains an positive integer n105 , and n lines follow. In each of these lines, there are 3 integers ri,ei,li , where 0ri,ei,li109 .

 


Output
For each test case: output ''Case #x: ans'' (without quotes), where x is the number of test cases, and ans is ''YES'' (without quotes) if DRD can pass all the courses, and otherwise ''NO'' (without quotes).

 


Sample Input
  
  
2 3 3 2 2 5 100 2 7 1000 2 3 3 10 2 5 100 2 7 1000 2
 


Sample Output
  
  
Case #1: NO Case #2: YES


恩,题目大意就是说,预习一科目所需时间,多久后考试开始,考试持续时间,问能否在所有时间不冲突的情况下完成所有科目,就排序然后更新一下(个人看法)


#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 100000+10
using namespace std;
struct Node
{
    int t,s,l;
};
Node node[maxn];
int cmp(Node a,Node b)
{
    return a.s<b.s;
}
int main()
{
    int t,n,cnt=0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;++i)
            scanf("%d%d%d",&node[i].t,&node[i].s,&node[i].l);
        sort(node,node+n,cmp);
        int flag=1;
        for(int i=0;i<n;++i)
        {
            if(node[i].t>node[i].s)
            {
                flag=0;
                break;
            }
            node[i+1].t+=node[i].t+node[i].l;
        }
        printf("Case #%d: ",++cnt);
        if(flag)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值