hdoj 5240 Exam【贪心】

Exam

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1067    Accepted Submission(s): 529


Problem Description
As this term is going to end, DRD needs to prepare for his final exams.

DRD has  n  exams. They are all hard, but their difficulties are different. DRD will spend at least  ri  hours on the  i -th course before its exam starts, or he will fail it. The  i -th course's exam will take place  ei  hours later from now, and it will last for  li  hours. When DRD takes an exam, he must devote himself to this exam and cannot (p)review any courses. Note that DRD can review for discontinuous time. 

So he wonder whether he can pass all of his courses. 

No two exams will collide. 
 

Input
First line: an positive integer  T20  indicating the number of test cases.
There are T cases following. In each case, the first line contains an positive integer  n105 , and  n  lines follow. In each of these lines, there are 3 integers  ri,ei,li , where  0ri,ei,li109

 

Output
For each test case: output ''Case #x: ans'' (without quotes), where  x  is the number of test cases, and  ans  is ''YES'' (without quotes) if DRD can pass all the courses, and otherwise ''NO'' (without quotes). 

 

Sample Input
  
  
2 3 3 2 2 5 100 2 7 1000 2 3 3 10 2 5 100 2 7 1000 2
 

Sample Output
  
  
Case #1: NO Case #2: YES
 

Source
 


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
struct node{
	ll re,be,last;//re复习时间,be考试开始时间,last考试持续时间; 
};					//考试开始时间一定要在复习时间之前! 
node p[110000];
bool cmp(node a, node b)
{
	return a.be < b.be;//按考试开始时间先后排序 
}
int main()
{
	int t,ca=1;
	scanf("%d", &t);
	while(t--)
	{
		int n;
		scanf("%d", &n);//n门考试 
		int i,j,k;
		for(i = 0; i < n; i++)
		{
			scanf("%lld%lld%lld", &p[i].re, &p[i].be, &p[i].last);
		}
		sort(p,p+n,cmp);//排序 
		int flag = 1;
		
		int a = p[0].be;//a 两场考试之间间隔时间 
		for(i = 0; i < n; i++)
		{
			if( i &&p[i].be < p[i-1].be+p[i-1].last){
				flag = 0; break;//考试时间冲突 无法通过所有考试 
			}
			if(i){
				a+=(p[i].be - p[i-1].be-p[i-1].last);//时间间隔 
			}
			if(a < p[i].re){//复习时间在考试开始之后,就无法通过这个考试,直接退出 
				flag = 0;break;
			}
			else{
				a-=p[i].re;//考试之间的时间间隔减去复习时间,可以接着复习下一门. 
			}
		}
		printf("Case #%d: ",ca++);
		if(flag)
			printf("YES\n");
		else
			printf("NO\n");	
	}
	return 0;
} 




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值