HDOJ 5596 GTW likes gt(巧解)



GTW likes gt

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 324    Accepted Submission(s): 113


Problem Description
Long long ago, there were n adorkable GT. Divided into two groups, they were playing games together, forming a column. The ith GT would randomly get a value of ability bi . At the ith second, the ith GT would annihilate GTs who are in front of him, whose group differs from his, and whose value of ability is less than his.

In order to make the game more interesting, GTW, the leader of those GTs, would emit energy for
m times, of which the ith time of emitting energy is ci . After the ci second, b1,b2,...,bci would all be added 1.

GTW wanted to know how many GTs would survive after the
nth second.
 

Input
The first line of the input file contains an integer T(5) , which indicates the number of test cases.

For each test case, there are
n+m+1 lines in the input file.

The first line of each test case contains 2 integers
n and m , which indicate the number of GTs and the number of emitting energy, respectively. (1n,m50000)

In the following
n lines, the ith line contains two integers ai and bi , which indicate the group of the ith GT and his value of ability, respectively. (0ai1,1bi106)

In the following
m lines, the ith line contains an integer ci , which indicates the time of emitting energy for ith time.
 

Output
There should be exactly T lines in the output file.

The
ith line should contain exactly an integer, which indicates the number of GTs who survive.
 

Sample Input
  
  
1 4 3 0 3 1 2 0 3 1 1 1 3 4
 

Sample Output
  
  
3
Hint
After the first seconds,$b_1=4,b_2=2,b_3=3,b_4=1$ After the second seconds,$b_1=4,b_2=2,b_3=3,b_4=1$ After the third seconds,$b_1=5,b_2=3,b_3=4,b_4=1$,and the second GT is annihilated by the third one. After the fourth seconds,$b_1=6,b_2=4,b_3=5,b_4=2$ $c_i$ is unordered.
 


题意:有n个GT排成一列,被分成两组,每个GT都会随机拥有bi点能量,到第i秒时第i个GT要消灭掉排在他前面的且与他不是一个组的比他能量低的GT。为了游戏更有意思,GT族的酋长会发功m次,第i次发功在ci秒,第ci秒结束后,  b1,b2,b3....bci都会增加1。 问第n秒后,还有几个GT。

题解:O(n*n)的傻瓜方法果断错了,比赛结束后看了OI爷的代码,学了一发O(n)法。从GT数列的最后端开始考虑,先将酋长在整个过程中给每个GT的能量全加上。然后从数列尾端开始将当前GT与最大值比较,大于最大值就表示能存活下来,然后更新最大值。

代码如下:

#include<cstdio> 
#include<cstring>
#include<algorithm>
using namespace std;
int a[50010],b[50010],s[50010];
int main()
{
	int n,m,i,c,t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(i=1;i<=n;++i)
			scanf("%d%d",&a[i],&b[i]);
		memset(s,0,sizeof(s));
		for(i=0;i<m;++i)
		{
			scanf("%d",&c);
			s[c]++;
		}
		for(i=n;i;--i)//越向前增加的能量越多
		{
			s[i]+=s[i+1];
			b[i]+=s[i];
		}
		int ans=0;
		int max1=-1,max2=-1;
		for(i=n;i;--i)
		{
			if(!a[i])
			{
				if(max2<=b[i])
					ans++;
				max1=max(max1,b[i]);
			}
			else
			{
				if(max1<=b[i])
					ans++;
				max2=max(max2,b[i]);
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值