HDOJ 5596 GTW likes gt 【思维 】

GTW likes gt

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 363    Accepted Submission(s): 130


Problem Description
Long long ago, there were n adorkable GT. Divided into two groups, they were playing games together, forming a column. The ith GT would randomly get a value of ability bi . At the ith second, the ith GT would annihilate GTs who are in front of him, whose group differs from his, and whose value of ability is less than his.

In order to make the game more interesting, GTW, the leader of those GTs, would emit energy for m times, of which the ith time of emitting energy is ci . After the ci second, b1,b2,...,bci would all be added 1.

GTW wanted to know how many GTs would survive after the nth second.
 

Input
The first line of the input file contains an integer T(5) , which indicates the number of test cases.

For each test case, there are n+m+1 lines in the input file.

The first line of each test case contains 2 integers n and m , which indicate the number of GTs and the number of emitting energy, respectively. (1n,m50000)

In the following n lines, the ith line contains two integers ai and bi , which indicate the group of the ith GT and his value of ability, respectively. (0ai1,1bi106)

In the following m lines, the ith line contains an integer ci , which indicates the time of emitting energy for ith time.
 

Output
There should be exactly T lines in the output file.

The ith line should contain exactly an integer, which indicates the number of GTs who survive.
 

Sample Input
  
  
1 4 3 0 3 1 2 0 3 1 1 1 3 4
 

Sample Output
  
  
3
Hint
After the first seconds,$b_1=4,b_2=2,b_3=3,b_4=1$ After the second seconds,$b_1=4,b_2=2,b_3=3,b_4=1$ After the third seconds,$b_1=5,b_2=3,b_3=4,b_4=1$,and the second GT is annihilated by the third one. After the fourth seconds,$b_1=6,b_2=4,b_3=5,b_4=2$ $c_i$ is unordered.
 

恩,题目大意就是说,分两队而站,后面是该人的能力值,然后之后的每次发功都可以使第1个到第c [ i ]个人的能力值都增加1同时第 i 个人可以打败他前面所有比他能力弱的人。恩,这一种是记录能力增加的次数

#include <iostream>
#include<cstdio>
#include<cstring>
#define maxn 50050
using namespace std;
int c[maxn];
struct Node
{
    int s,p;
};
Node node[maxn];
int main()
{
    int T,n,m,p;
    scanf("%d\n",&T);
    while(T--)
    {
        memset(c,0,sizeof(c));
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;++i)
            scanf("%d%d",&node[i].s,&node[i].p);
        c[0]=c[n+1]=0;
        for(int i=1;i<=m;++i)
        {
            scanf("%d",&p);
            c[p]++;
        }
        for(int i=n;i>=1;i--)
            c[i]+=c[i+1];
        int ans=n;
        int max0=-9999999;
        int max1=-9999999;
        for(int i=n;i>=1;i--)
        {
            if(node[i].s)
            {
                if(node[i].p+c[i]<max0)
                    ans--;
                max1=max(max1,node[i].p+c[i]);
            }
            else
            {
                if(node[i].p+c[i]<max1)
                    ans--;
                max0=max(max0,node[i].p+c[i]);
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}



恩,从第1到第c [i ]个人能力的增加相当于第c [ i+1 ] 人之后所有人的能力值减1 ,这个就是记录减的


#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 50050
using namespace std;
int c[maxn];
struct Node
{
    int pos,val;
};
Node node[maxn];
int main()
{
    int T,n,m,p;
    scanf("%d",&T);
    while(T--)
    {
        memset(c,0,sizeof(c));
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;++i)
            scanf("%d%d",&node[i].pos,&node[i].val);
        c[0]=c[n+1]=0;
        for(int i=1;i<=m;++i)
        {
            scanf("%d",&p);
            c[p+1]++;
        }
        for(int i=1;i<=n;++i)
        {
            c[i]+=c[i-1];
            node[i].val-=c[i];
        }
        int ans=0;
        int max0=-99999999,max1=-99999999;
        for(int i=n;i>=1;i--)
        {
            if(node[i].pos)
            {
                if(node[i].val>=max0)
                    ans++;
                max1=max(max1,node[i].val);
            }
            else
            {
                if(node[i].val>=max1)
                    ans++;
                max0=max(max0,node[i].val);
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

恩,还可以用树状数组和线段树做,但我还木写出来。。。。



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值