POJ 2139 Six Degrees of Cowvin Bacon(最短路—dijkstra算法)

Six Degrees of Cowvin Bacon

Time Limit: 1000MS


Memory Limit: 65536K

Total Submissions: 3993


Accepted: 1876

Description

The cows have been making movies lately, so they are ready to play a variant of the famous game "Six Degrees of Kevin Bacon". 

The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one 'degree' away from the other. If a two cows have never worked together but have both worked with a third cow, they are considered to be two 'degrees' away from each other (counted as: one degree to the cow they've worked with and one more to the other cow). This scales to the general case. 

The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship path exists between every pair of cows. 

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers tell which cows were. 

Output

* Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows. 

Sample Input

4 2
3 1 2 3
2 3 4

Sample Output

100

Hint

[Cow 3 has worked with all the other cows and thus has degrees of separation: 1, 1, and 1 -- a mean of 1.00 .] 


题意:如果两头牛在同一部电影中出现过,那么这两头牛的度就为1, 如果这两头牛a,b没有在同一部电影中出现过,但a,b分别与c在同一部电影中出现过,那么a,b的度为2。以此类推,a与b之间有n头媒介牛,那么a,b的度为n+1。 给出m部电影,每一部给出牛的个数,和牛的编号。问那一头到其他每头牛的度数平均值最小,输出最小平均值乘100。

题解:到所有牛的度数的平均值最小,也就是到所有牛的度数总和最小。那么就是找这头牛到其他每头牛的最小度,也就是最短路径,相加再除以(n-1)就是最小平均值。对于如何确定这头牛,我们可以枚举,最后记录最下平均值即可。

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f
int map[310][310],dis[310];
int a[310];
int n;

void dijkstra(int x)
{
	int visit[310];
	int i,j,min,next=0;
	memset(visit,0,sizeof(visit));
	for(i=1;i<=n;++i)
	{
		dis[i]=map[x][i];
	}
	visit[x]=1;
	for(i=2;i<=n;++i)
	{
		min=INF;
		for(j=1;j<=n;++j)
		{
			if(!visit[j]&&min>dis[j])
			{
				next=j;
				min=dis[j];
			}
		}
		visit[next]=1;
		for(j=1;j<=n;++j)
		{
			if(!visit[j]&&dis[j]>dis[next]+map[next][j])
				dis[j]=dis[next]+map[next][j];
		}
	}
}

int main()
{
	int m,i,num,j;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		for(i=1;i<=n;++i)
		{
			for(j=1;j<=n;++j)
			{
				if(i==j)
					map[i][j]=0;
				else
					map[i][j]=map[j][i]=INF;//初始化一定要为极大值 
			}
		}
		while(m--)
		{
			scanf("%d",&num);
			for(i=0;i<num;++i)
				scanf("%d",&a[i]);
			for(i=0;i<num;++i)
			{
				for(j=0;j<num;++j)
				{
					if(a[i]!=a[j])
						map[a[i]][a[j]]=map[a[j]][a[i]]=1;
				}
			} 
		}
		double ans=INF;
		for(i=1;i<=n;++i)//枚举每一头牛 
		{
			double sum=0;
			dijkstra(i);
			for(j=1;j<=n;++j)//记录到其他牛的度数之和 
			{
				if(i!=j)
					sum+=dis[j];
			}
			ans=min(ans,sum*1.0/(n-1));
		}
		printf("%d\n",(int)(ans*100));
	}
	return 0;
} 




  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值