HDOJ 1028 Ignatius and the Princess III(母函数—整数拆分模板题)



Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16743    Accepted Submission(s): 11784


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
  
  
4 10 20
 

Sample Output
  
  
5 42 627
 

题意很简单,就不写了。

题解:母函数模板题,整数拆分,展开多项式,指数为n的项的系数就是拆分数,具体解释,理解见代码。

代码如下:

#include<cstdio>
#include<cstring>
int c1[130],c2[130];//c1[i]表示指数为i的项的系数,c2[]储存中间变量 
int main()
{
	int n,i,j,k;//k表示指数 
	while(scanf("%d",&n)!=EOF)
	{
		for(i=0;i<=n;++i)//初始化c1为1,代表第一个多项式前面的系数全为1 
		{
			c1[i]=1;  c2[i]=0;
		}
		for(i=2;i<=n;++i)//从第二个多项式开始,一共有n个多项式 
		{
			for(j=0;j<=n;++j)//j表示进行一次表达式相乘后,第一个表达式的的第j个变量 
			{
				for(k=0;k+j<=n;k+=i)//此处表示第一个表达式的第j个变量遍历第二个表达式 (逻辑上的第i个表达式)
					c2[k+j]+=c1[j];//c1[j]存储的是上一次运算结束后一个表达式中指数为j的系数,因为此时的第二个表达式的所有的系数均为1,其实就是将便利的过程中的拥有k+j指数的系数加1 
			}
			for(j=0;j<=n;++j)//将c2存储的系数赋值给相应的c1,然后清零c2
			{
				c1[j]=c2[j];
				c2[j]=0;
			}
		}
		printf("%d\n",c1[n]);
	}
	return 0;
}//以上就是模拟多项式展开的过程,有不理解的地方,在稿纸上模拟几遍就好了 



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值