HDU 5364 Distribution money

Problem Description
AFA want to distribution her money to somebody.She divide her money into n same parts.One who want to get the money can get more than one part.But if one man's money is more than the sum of all others'.He shoule be punished.Each one who get a part of money would write down his ID on that part.

Input
There are multiply cases.
For each case,there is a single integer n(1<=n<=1000) in first line.
In second line,there are n integer a1,a2...an(0<=ai<10000)ai is the the ith man's ID.


sample input
3
1 1 2
4
2 1 4 3

sample output

1
-1




题意

地主给排着队的长工发工资,每份工资是一样的,领了工资的人会留下工号,但是有的人对领完之后回到队尾再领,如果有人领的工资比其他所有人只和还多,试求是否有这样的人以及他的编号。

题解

题意也就是寻找序列中出现次数超过一半的元素,可以先排序,然后计算中间位置元素的数量(二分),超过一半就是答案,小于一半则无解


#include<stdio.h>
#include<iostream>
#include<algorithm>

using namespace std;

int a[1002];

int main(void)
{
    //freopen ("in.txt","r",stdin);
    int n,k;
    
    while (scanf("%d",&n)!=EOF)
    {
        for (int i=1;i<=n;++i) scanf("%d",&a[i]);
        sort(a+1,a+1+n);
        k=a[(1+n)/2];
        if (upper_bound(a+1,a+1+n,k)-lower_bound(a+1,a+1+n,k)>n/2) printf("%d\n",k);
        else printf("-1\n");
        
    }
    
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值