1015 Reversible Primes (20 分)

1015 Reversible Primes (20 分)

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

 ======================================

思路:

输入的 n 永远是十进制下的值,d是 n 的进制。判断 n 是否是素数。

需要把 十进制下的 n 转化为 d 进制后,再反转。

求出十进制 sum。判断 sum 是否是素数。

比如第二组数据:

23 2

 23是素数,转化为二进制是10111,反转后是11101(十进制为29),29也是素数,所以他是。

两者都是素数,则输出Yes,否则输出No。

 

另外注意这种转换为10进制的写法:

         for(int i = 0; i < len; i++)    //转为10进制
             n = n * d + arr[i];  

好好体会。或者用这种转化10进制的方法:

    for(int i = 0; i < len; i++)
            n += arr[i] * pow(d, len - i - 1);   

======================================

#include <iostream>
using namespace std;
bool isPrime(int n){
	if(n <= 1) return false;
	for(int i = 2; i * i <= n; i++)
		if(n % i == 0) return false;
	return true;
}
int main(){
	int n, d;
	while(scanf("%d", &n) != EOF){
		if(n < 0) break;
		scanf("%d", &d);
		if(isPrime(n) == false) {
	 		printf("No\n");
 			continue;
 		}
 		int len = 0, arr[100];
 		do{
 			arr[len++] = n % d;
 			n = n / d;
 		}while(n != 0);    //除基取余,并没有倒排,所以就是反转后的顺序
 		for(int i = 0; i < len; i++)    //转为10进制
 			n = n * d + arr[i];   
 		printf("%s", isPrime(n) ? "Yes\n" : "No\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值