1015 Reversible Primes (20分)

测试地址:

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

题意:如果 n 是一个素数,并且 n 转化成 d 进制数进行翻转,翻转后转换成的十进制数也是素数,则输出“Yes”,否则输出“No”。

思路:先判断 n 是否是一个素数,如果 n 不是素数,直接输出“No”;如果 n 是素数,再去判断 n 在 d 进制下翻转之后的十进制数是否是素数,如果是,输出“Yes”;否则,输出“No”。

c++代码: 

#include<iostream>
#include<cmath>
#include<cstring>
using namespace std;
int sushu(int n);
int radix(int n, int d){
	int a[10010];
	int t, sum;
	t = sum = 0;
	memset(a, 0, sizeof(a));
	while(n > 0){
		a[t] = n%d;
		n /= d;
		t++;
	}
	for(int i = 0; i < t; i++){
		sum += a[i]*pow(d, t-i-1);    //sum = sum*d+a[i];
	}
	return sum;
}
int sushu(int n){
	if(n < 2) 	return 0;
	for(int i = 2; i <= sqrt(n); i++){
		if(n%i == 0){
			return 0;
		}
	}
	return 1;
}
int main(){
	int n, d;
	while(true){
		cin >> n;
		if(n < 0)	break;
		cin >> d;
		if( sushu(n) ){
			if(sushu(radix(n, d)))
				cout << "Yes" << endl;
			else
				cout << "No" << endl;
                //printf("%s", sushu(radix(n, d)) ? "Yes\n" : "No\n");
                //cout << (sushu(radix(n, d)) ? "Yes\n" : "No\n");
		}
		else{
			cout << "No" << endl;
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值