1015 Reversible Primes (20 分)

 

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

C:

/*
 @Date    : 2017-11-29 17:46:54
 @Author  : 酸饺子 (changzheng300@foxmail.com)
 @Link    : https://github.com/SourDumplings
 @Version : $Id$
*/

/*
https://www.patest.cn/contests/pat-a-practise/1015
 */

#include <stdio.h>
#include <math.h>

int GetReverseValue(int N, int D)
{
    int d_n[100];
    int i;
    for (i = 0; N; i++)
    {
        d_n[i] = N % D;
        // printf("$$d_n[%d] = %d$$\n", i, d_n[i]);
        N /= D;
    }
    int temp = 1;
    int result = 0;
    for (i -= 1; i >= 0; i--)
    {
        result += d_n[i] * temp;
        temp *= D;
    }
    return result;
}

int IsPrime(int N)
{
    if (N == 2)
    {
        return 1;
    }
    else if (N % 2 == 0 || N == 0 || N == 1)
    {
        return 0;
    }
    else
    {
        int i;
        for (i = 3; i <= sqrt(N); i += 2)
        {
            if (N % i == 0)
            {
                // printf("%d is a composite number, it has factor %d.\n", N, i);
                return 0;
            }
        }
        // printf("%d is a prime number.\n", N);
        return 1;
    }
}

int main()
{
    int N, D;
    int flag;
    while (1)
    {
        scanf("%d", &N);
        if (N < 0)
        {
            break;
        }
        else
        {
            scanf("%d", &D);
            flag = IsPrime(N);
            if (flag)
            {
                N = GetReverseValue(N, D);
                // printf("$$Its reverse value is %d.$$\n", N);
                flag = IsPrime(N);
            }
            if (flag)
            {
                printf("Yes\n");
            }
            else
            {
                printf("No\n");
            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值