HD4185Oil Skimming

Oil Skimming

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1260    Accepted Submission(s): 512


Problem Description
Thanks to a certain "green" resources company, there is a new profitable industry of oil skimming. There are large slicks of crude oil floating in the Gulf of Mexico just waiting to be scooped up by enterprising oil barons. One such oil baron has a special plane that can skim the surface of the water collecting oil on the water's surface. However, each scoop covers a 10m by 20m rectangle (going either east/west or north/south). It also requires that the rectangle be completely covered in oil, otherwise the product is contaminated by pure ocean water and thus unprofitable! Given a map of an oil slick, the oil baron would like you to compute the maximum number of scoops that may be extracted. The map is an NxN grid where each cell represents a 10m square of water, and each cell is marked as either being covered in oil or pure water.
 

Input
The input starts with an integer K (1 <= K <= 100) indicating the number of cases. Each case starts with an integer N (1 <= N <= 600) indicating the size of the square grid. Each of the following N lines contains N characters that represent the cells of a row in the grid. A character of '#' represents an oily cell, and a character of '.' represents a pure water cell.
 

Output
For each case, one line should be produced, formatted exactly as follows: "Case X: M" where X is the case number (starting from 1) and M is the maximum number of scoops of oil that may be extracted.
 

Sample Input
  
  
1 6 ...... .##... .##... ....#. ....## ......
 

Sample Output
  
  
Case 1: 3
 
这道题看题解说是二分匹配,想了半天也不知道怎么匹配,最后看了分析,好妙!
首先遍历一遍整个图,给‘#’,编个号。然后在遍历一遍将‘#’与上下左右建立一个联系,然后就是匈牙利算法了,注意的是最后结果的除以二。因为是上下左右建立的联系。
#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int map[605][605],pos[605][605];
int used[605],link[605];
char a[605][605];
int n,sum;
int find(int x)
{
    for(int i=1;i<=sum;i++)
    {
        if(map[x][i]==1&&used[i]==0)
        {
            used[i]=1;
            if(link[i]==0||find(link[i]))
            {
                link[i]=x;
                return 1;
            }
        }
    }
    return 0;
}

int main()
{
    int t;
    scanf("%d",&t);
    int count=0;
    while(t--)
    {
        scanf("%d",&n);
        getchar();
        sum=0;
        memset(pos,0,sizeof(pos));
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                scanf("%c",&a[i][j]);
                if(a[i][j]=='#')
                    pos[i][j]=++sum;
            }
            getchar();
        }
        memset(map,0,sizeof(map));
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(a[i][j]=='#')
                {
                    if(i-1>0&&pos[i-1][j]!=0)
                        map[pos[i][j]][pos[i-1][j]]=1;
                    if(j-1>0&&pos[i][j-1]!=0)
                        map[pos[i][j]][pos[i][j-1]]=1;
                    if(i+1<=n&&pos[i+1][j]!=0)
                        map[pos[i][j]][pos[i+1][j]]=1;
                    if(j+1<=n&&pos[i][j+1]!=0)
                        map[pos[i][j]][pos[i][j+1]]=1;
                }
            }
        }
        int all=0;
        memset(link,0,sizeof(link));
        for(int i=1;i<=sum;i++)
        {
            memset(used,0,sizeof(used));
            if(find(i)) all++;
        }
        printf("Case %d: %d\n",++count,all/2);

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
毕业设计,基于SpringBoot+Vue+MySQL开发的纺织品企业财务管理系统,源码+数据库+毕业论文+视频演示 在如今社会上,关于信息上面的处理,没有任何一个企业或者个人会忽视,如何让信息急速传递,并且归档储存查询,采用之前的纸张记录模式已经不符合当前使用要求了。所以,对纺织品企业财务信息管理的提升,也为了对纺织品企业财务信息进行更好的维护,纺织品企业财务管理系统的出现就变得水到渠成不可缺少。通过对纺织品企业财务管理系统的开发,不仅仅可以学以致用,让学到的知识变成成果出现,也强化了知识记忆,扩大了知识储备,是提升自我的一种很好的方法。通过具体的开发,对整个软件开发的过程熟练掌握,不论是前期的设计,还是后续的编码测试,都有了很深刻的认知。 纺织品企业财务管理系统通过MySQL数据库与Spring Boot框架进行开发,纺织品企业财务管理系统能够实现对财务人员,员工,收费信息,支出信息,薪资信息,留言信息,报销信息等信息的管理。 通过纺织品企业财务管理系统对相关信息的处理,让信息处理变的更加的系统,更加的规范,这是一个必然的结果。已经处理好的信息,不管是用来查找,还是分析,在效率上都会成倍的提高,让计算机变得更加符合生产需要,变成人们不可缺少的一种信息处理工具,实现了绿色办公,节省社会资源,为环境保护也做了力所能及的贡献。 关键字:纺织品企业财务管理系统,薪资信息,报销信息;SpringBoot
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值