POJ2488 A Knight's Journey(DFS)

6 篇文章 0 订阅

 

A Knight's Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 36767 Accepted: 12489

Description

Background  
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey  
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?  

Problem  
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.  
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
 
题意:马要走完所有的点,可以给出路径,否则impossible
这道题做的血槽已空,20分钟就敲完了,然后就在卡数据,卡的最后一个样例后面的老是不对,之后才发现要按照字典序输出,所以gx,gy就不能乱走,改完之后输出对了,还是wrong answer,郁闷,检查提交wa,在提交wa,一度怀疑judge出问题了,今天早上又看了一遍,发现gx,gy,将x,y弄得反了,真是晕死了,晕的死死了,白白贡献这么多的wa;
棋盘横着的是A...Z,竖着的是1234...输出先输出y,再输出x
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <string.h>
#include <algorithm>
using namespace std;
const int MAX = 30;
struct Node
{
    int x,y;
};
Node node[MAX*MAX];
int vis[MAX][MAX];
int p,q,flag;
int gx[8] = {-1,1,-2,2,-2,2,-1,1};
int gy[8] = {-2,-2,-1,-1,1,1,2,2};
void dfs(int x,int y,int cnt)
{
    if(cnt == p*q)
    {
        flag = 1;
        for(int i = 0; i < p*q; i++)
            printf("%c%d",node[i].y + 'A',node[i].x + 1);
        printf("\n");
        return;
    }
    if(flag) return;
    for(int i = 0; i < 8; i++)
    {
        int fx = x + gx[i];
        int fy = y + gy[i];
        if(fx >= 0 && fy >= 0 && fx < p && fy < q)
        {
            if(vis[fx][fy] == 0)
            {
                vis[fx][fy] = 1;
                node[cnt].x = fx;
                node[cnt].y = fy;
                dfs(fx,fy,cnt + 1);
                if(flag)
                    return;
                vis[fx][fy] = 0;
            }
        }
    }
}
int main()
{
    int t,num = 0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&p,&q);
        flag = 0;
        printf("Scenario #%d:\n",++num);
        for(int i = 0; i < p; i++)
        {
            for(int j = 0; j < q; j++)
            {
                if(flag)
                    break;
                memset(vis,0,sizeof(vis));
                node[0].x = i;
                node[0].y = j;
                vis[i][j] = 1;
                dfs(i,j,1);
            }
            if(flag)
                break;
        }
        if(flag == 0)
            printf("impossible\n");
        printf("\n");
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值