POJ1860 兑换货币(最短路)

Currency Exchange
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 32602 Accepted: 12433

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively. 
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

题目要求用已知货币经过数次兑换,换得更多货币,最终用初始货币种类来表示。

Bellman Ford算法的松弛计算可以判断图中是否存在副权回路,即经过n-1次松弛计算后,如果依旧存在dis[edge[j].b]<dis[edge[j].a]+edge[a].cost,图中必然有副权回路。

此题相反,要求货币数量变多,即存在正权回路,由此可得出解法。

bool bellman_ford()
{
memset(dis,0,sizeof(dis));
dis[s] = v;
bool flag;
for(int i=1;i<=n-1;i++)
{
flag = false;
for(int j=0;j<all;j++)
if(dis[edge[j].b]<(dis[edge[j].a]-edge[j].cost)*edge[j].rate)
 {
  dis[edge[j].b]=(dis[edge[j].a]-edge[j].cost)*edge[j].rate;
  flag = true;
 }
if(!flag) break;
    }
   for(int j=0;j<all;j++)
    if(dis[edge[j].b]<(dis[edge[j].a]-edge[j].cost)*edge[j].rate)
     return true;
    return false;
}

与标准的Bellman Ford相比,此题的不同处在于,初始化dis数组时,起始点dis[s]为v,其余点都为0,而不是无穷大。

此题没有给出边的数量,因此需要all来计算边数。

底下是全部代码。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define maxn 99999999;
int n,m,s,all;
double v;
struct Edge{
int a;
int b;
double rate;
double cost;
}edge[1010];
double dis[1010];
bool bellman_ford()
{
memset(dis,0,sizeof(dis));
dis[s] = v;
bool flag;
for(int i=1;i<=n-1;i++)
{
flag = false;
for(int j=0;j<all;j++)
if(dis[edge[j].b]<(dis[edge[j].a]-edge[j].cost)*edge[j].rate)
 {
  dis[edge[j].b]=(dis[edge[j].a]-edge[j].cost)*edge[j].rate;
  flag = true;
 }
if(!flag) break;
    }
   for(int j=0;j<all;j++)
    if(dis[edge[j].b]<(dis[edge[j].a]-edge[j].cost)*edge[j].rate)
     return true;
    return false;
}
int main()
{
//freopen("d://test.txt","r",stdin);
int a,b;
double rab,rba,cab,cba;
    while(cin>>n>>m>>s>>v)
    {
    all = 0;
while(m--)
{
cin>>a>>b>>rab>>cab>>rba>>cba;
edge[all].a = a;
edge[all].b = b;
edge[all].rate = rab;
edge[all++].cost = cab;
edge[all].a = b;
edge[all].b = a;
edge[all].rate = rba;
edge[all++].cost = cba;
     }
if(bellman_ford()) cout<<"YES"<<endl;
else cout<<"NO"<<endl;
    }
return 0;
}

PS:本题被卡了半天是因为题目要求输出YES,眼瞎打成了Yes。。。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

总想玩世不恭

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值