UESTC - 278 Fibonacci

In the Fibonacci integer sequence, F0=0,F1=1,F0=0,F1=1, and Fn=Fn−1+Fn−2Fn=Fn−1+Fn−2 for n≥2n≥2. For example, the first ten terms of the Fibonacci sequence are:

0,1,1,2,3,5,8,13,21,34,⋯0,1,1,2,3,5,8,13,21,34,⋯
An alternative formula for the Fibonacci sequence is
这里写图片描述
Given an integer nn, your goal is to compute the last 44 digits of FnFn.
Input
The input test file will contain multiple test cases. Each test case consists of a single line containing nn (where 0≤n≤1,000,000,0000≤n≤1,000,000,000).

The end-of-file is denoted by a single line containing the number -1.

Output
For each test case, print the last four digits of FnFn. If the last four digits of FnFn are all zeros, print 0; otherwise, omit any leading zeros (i.e., print FnFn mod 1000010000).

Sample Input
0
9
999999999
1000000000
-1
Sample Output
0
34
626
6875
Hint
As a reminder, matrix multiplication is associative, and the product of two 2×22×2 matrices is given by
这里写图片描述
Also, note that raising any 2×22×2 matrix to the 0th power gives the identity matrix:
这里写图片描述
The data used in this problem is unofficial data prepared by 695375900. So any mistake here does not imply mistake in the offcial judge data.

例:
a^11=a^(2^0+2^1+2^3)
普通的快速幂(a^b%c)
int quick_pow(int a,int b,int c)
{
    int ans=1;
    while(b)
    {
        if(b&1)
            ans=ans*a%c;
        a=a*a%c
        b>>=1;
    }
    return ans;
}
#include<stdio.h>
#include<string.h>
struct mat
{
    int a[2][2];
};
mat I=
{
    1,0,
    0,1
};
mat matrax(mat q,mat p)
{
    mat e;
    memset(e.a,0,sizeof(e.a));
    for(int i=0; i<2; i++)
        for(int j=0; j<2; j++)
        {
            for(int k=0; k<2; k++)
            {
                e.a[i][j]=(e.a[i][j]+q.a[i][k]*p.a[k][j])%10000;
            }
        }
    return e;
}
mat quicklymod(mat b,int n)
{
    mat ans;
    memset(ans.a,0,sizeof(ans.a));
    ans=I;
    while(n)
    {
        if(n&1)
            ans=matrax(b,ans);
        b=matrax(b,b);
        n>>=1;
    }
    return ans;
}
int main()
{
    int n;
    while(~scanf("%d",&n)&&n!=-1)
    {
        mat b;
        b.a[0][0]=1,b.a[0][1]=1,b.a[1][0]=1,b.a[1][1]=0;
        if(n<=2)
        {
            if(n==0) printf("0\n");
            else if(n==1) printf("1\n");
            else if(n==2) printf("1\n");
        }
        else
        {
            b=quicklymod(b,n);
            printf("%d\n",b.a[0][1]);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
互联网络程序设计是指在互联网上进行程序开发和设计的过程。UESTC则是我国的一所著名高校——电子科技大学。 互联网络程序设计 uestc包含了两个主要的方面:互联网络和程序设计。互联网络是指将多个计算机网络通过通信链路互相连接起来,实现信息共享和资源共享的网络系统。程序设计是指根据需求和目标,通过编写代码和设计算法,实现计算机程序的过程。 互联网络程序设计 uestc的学习内容主要包括以下几个方面: 1. 网络知识:学习互联网络的基本概念、原理和协议,如TCP/IP协议、HTTP协议等。掌握网络编程的基本技术,能够编写网络应用程序。 2. 数据通信:学习数据通信的基本原理和技术,包括数据传输的方式、数据压缩和加密等。了解网络安全和数据保护的基本知识。 3. 程序设计:学习编程语言和开发工具,如Java、C++和Python等。掌握常用的编程技巧和方法,能够设计和实现复杂的网络应用程序。 4. Web开发:学习Web开发的基本知识和技术,包括HTML、CSS、JavaScript等。能够设计和实现交互式的Web应用程序。 5. 数据库技术:学习数据库的基本原理和技术,如SQL语言和数据库管理系统。能够设计和管理数据库,实现数据的存储和检索。 通过学习互联网络程序设计 uestc,可以掌握互联网应用开发的基本技能,具备设计和实现网络应用程序的能力。这对于目前互联网行业的人才需求来说是非常重要的,也为学生提供了广阔的就业和创业机会。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值