HDU 3829 Cat VS Dog 最大独立集(最大匹配)

Cat VS Dog

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 125536/65536 K (Java/Others)
Total Submission(s): 3570    Accepted Submission(s): 1259


Problem Description
The zoo have N cats and M dogs, today there are P children visiting the zoo, each child has a like-animal and a dislike-animal, if the child's like-animal is a cat, then his/hers dislike-animal must be a dog, and vice versa.
Now the zoo administrator is removing some animals, if one child's like-animal is not removed and his/hers dislike-animal is removed, he/she will be happy. So the administrator wants to know which animals he should remove to make maximum number of happy children.
 

Input
The input file contains multiple test cases, for each case, the first line contains three integers N <= 100, M <= 100 and P <= 500.
Next P lines, each line contains a child's like-animal and dislike-animal, C for cat and D for dog. (See sample for details)
 

Output
For each case, output a single integer: the maximum number of happy children.
 

Sample Input
  
  
1 1 2 C1 D1 D1 C1 1 2 4 C1 D1 C1 D1 C1 D2 D2 C1
 

Sample Output
  
  
1

3

思路:所有喜欢狗的孩子划到左边集合,喜欢猫的孩子划到右边集合,这样构成一个二分图。当左边的孩子喜欢的狗和右边的讨厌的狗相同或左边的孩子讨厌的猫和右边的孩子喜欢的猫相同时建边。这样问题转化为最大独立集。

最大独立集=节点数-最大匹配数。

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
typedef struct
{
	int c,like,dlike;
}H;
H l[550],r[550];
int map[550][550],vis[550],flag[550],nx,ny;
int find(int k);
int main()
{
	int n,i,j,k,sum,m,p,x,y;char a,b;
	while(scanf("%d%d%d",&n,&m,&p)!=EOF)
	{
		nx=1;ny=1;
		memset(map,0,sizeof(map));
		memset(flag,0,sizeof(flag));
		for(i=1;i<=p;i++)
		{
			scanf(" %c%d %c%d",&a,&x,&b,&y);
			if(a=='D')
			{
				l[nx].like=x;
				l[nx].dlike=y;
				l[nx++].c=i;
			}
			else
			{
				r[ny].like=x;
				r[ny].dlike=y;
				r[ny++].c=i;
			}
		}
		for(i=1;i<nx;i++)
		{
			for(j=1;j<ny;j++)
			{
				if(l[i].like==r[j].dlike)
					map[l[i].c][r[j].c]=1;
				if(l[i].dlike==r[j].like)
					map[l[i].c][r[j].c]=1;
			}
		}
		sum=0;
		for(i=1;i<nx;i++)
		{
			memset(vis,0,sizeof(vis));
			if(find(l[i].c))
				sum++;
		}
		printf("%d\n",p-sum);
	}
	return 0;
}
int find(int k)
{
	int i,j,u,v;
	for(j=1;j<ny;j++)
	{
		u=k;v=r[j].c;
	//	printf("%d %d\n",u,v);
		if(!vis[v] && map[u][v])
		{
			vis[v]=1;
			//printf("%d %d\n",u,v);
			if(!flag[v] || find(flag[v]))
			{
				flag[v]=u;
				return 1;
			}
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值