POJ1542 Ultra-QuickSort

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
pair<int,int>v[500005];
int dp[500004],a[500005],b[500005];
int bit[500005+1],n;
int sum(int i);
void add(int i,int x);
int main()
{
	int i,j,k;
	while(scanf("%d",&n),n!=0)
	{
		for(i=0;i<n;i++)
		{
			scanf("%d",&v[i].first);
			v[i].second=i;
		}
		sort(v,v+n);
		b[0]=1;
		a[v[0].second]=1;
		for(i=1;i<n;i++)
		{
			if(v[i].first>v[i-1].first)
				b[i]=b[i-1]+1;
			else
				b[i]=b[i-1];
			a[v[i].second]=b[i];
		}
		memset(bit,0,sizeof(bit));
		long long ans;
		ans=0;
		for(i=0;i<n;i++)
		{
			ans+=i-sum(a[i]);
			add(a[i],1);
		}
		printf("%lld\n",ans);
	}
	return 0;
}
int sum(int i)
{
	int s=0;
	while(i>0)
	{
		s+=bit[i];
		i-=i& -i;
	}
	return s;
}
void add(int i,int x)
{
	while(i<=n)
	{
		bit[i]+=x;
		i+=i & -i;
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值