HDU 4734 F(x) 数位DP

F(x)

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6398    Accepted Submission(s): 2465


Problem Description
For a decimal number x with n digits (A nA n-1A n-2 ... A 2A 1), we define its weight as F(x) = A n * 2 n-1 + A n-1 * 2 n-2 + ... + A 2 * 2 + A 1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).
 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 10 9)
 

Output
For every case,you should output "Case #t: " at first, without quotes. The  t is the case number starting from 1. Then output the answer.
 

Sample Input
  
  
3 0 100 1 10 5 100
 

Sample Output
  
  
Case #1: 1 Case #2: 2

Case #3: 13

#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<math.h>
#include<vector>
using namespace std;
const int maxm = 10005;
int dp[10][maxm], d[10], a, b, rev;
int dfs(int len, int num, int flag)
{
	if (len < 0) return num >= 0;
	if (num < 0) return 0;
	if (!flag&&dp[len][num] != -1 && num != 1)
		return dp[len][num];
	int k = flag ? d[len] : 9;
	int ans = 0, next;
	for (int i = 0;i <= k;i++)
		ans += dfs(len - 1, num - i*(1 << len), flag&&i == k);
	if (!flag) dp[len][num] = ans;
	return ans;
}
int query(int n)
{
	int len = 0;
	while (n) d[len++] = n % 10, n /= 10;
	return dfs(len - 1, rev, 1);
}
int main()
{
	int t, s;
	memset(dp, -1, sizeof(dp));
	scanf("%d", &t);
	for (int i = 1;i <= t;i++)
	{
		scanf("%d%d", &a, &b);
		printf("Case #%d: ", i);
		rev = 0;s = 0;
		while (a)
		{
			rev += (a % 10)*pow(2, s++);
			a /= 10;
		}
		printf("%d\n", query(b));
	}
	return 0;
}
/*
3
0 100
*/


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值