Time Limit:500MS Memory Limit:32768KB 64bit IO Format:%lld & %llu
Submit
Status
Practice
LightOJ 1022
Description
A circle is placed perfectly into a square. The term perfectly placed means that each side of the square is touched by the circle, but the circle doesn’t have any overlapping part with the square. See the picture below.
Now you are given the radius of the circle. You have to find the area of the shaded region (blue part). Assume that pi = 2 * acos (0.0) (acos means cos inverse).
Input
Input starts with an integer T (≤ 1000), denoting the number of test cases.
Each case contains a floating point number r (0 < r ≤ 1000) denoting the radius of the circle. And you can assume that r contains at most four digits after the decimal point.
Output
For each case, print the case number and the shaded area rounded to two places after the decimal point.
Sample Input
3
20
30.091
87.0921
Sample Output
Case 1: 343.36
Case 2: 777.26
Case 3: 6511.05
第一次用acos这样的函数orz acos(0.0)=pi/2;
然后煞笔一般的尝试了pi要精确到小数点后几位才能过。11位orz
感觉一些精度的东西和高中学的有点出入orzzz迷之精度
#include <cstdio>
#include <iostream>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;
const double pi=2*acos(0.0);
int main(){
freopen("in.txt","r",stdin);
int n,p=0;
double r;
cin>>n;
while(n--){
cin>>r;p++;
// printf("%.20f\n",pi);
printf("Case %d: %.2f\n",p,(4-pi)*r*r);
}
}