1.
定义一个二维数组:
int maze[5][5] = { 0, 1, 0, 0, 0, 0, 1, 0, 1, 0, 0, 0, 0, 0, 0, 0, 1, 1, 1, 0, 0, 0, 0, 1, 0, };
它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0 0 1 0 1 0 0 0 0 0 0 0 1 1 1 0 0 0 0 1 0
Sample Output
(0, 0) (1, 0) (2, 0) (2, 1) (2, 2) (2, 3) (2, 4) (3, 4) (4, 4)
思路:这个最主要的是将所走的最短路经过的点记录下来,用广搜。
代码:
#include<cstdio>
#include<cstring>
char a[100][100];
bool book[100][100];
int z[4][2]={{-1,0},{1,0},{0,-1},{0,1}};
struct pp
{
int x;
int y;
}q[10000],qe[100][100];
void print(int x,int y)
{
if(x==-1&&y==-1)
return;
print(qe[x][y].x,qe[x][y].y);
printf("(%d, %d)\n",x,y);
}
void bfs(int sx,int sy,int ex,int ey)
{
int hh=1,tt=1;
memset(book,0,sizeof(book));
book[0][0]=1;
qe[0][0].x=-1;
qe[0][0].y=-1;
q[tt].x=0;
q[tt].y=0;
tt++;
while(hh<tt)
{
int x=q[hh].x;
int y=q[hh].y;
if(x==4&&y==4)
{
print(x,y);
break;
}
for(int i=0;i<4;i++)
{
int tx=x+z[i][0];
int ty=y+z[i][1];
if(tx>=0&&tx<5&&ty>=0&&ty<5&&book[tx][ty]==0&&a[tx][ty]==0)
{
book[tx][ty]=1;
q[tt].x=tx;
q[tt].y=ty;
tt++;
qe[tx][ty].x=x;
qe[tx][ty].y=y;
}
}
hh++;
}
}
int main()
{
for(int i=0;i<5;i++)
for(int j=0;j<5;j++)
scanf("%d",&a[i][j]);
bfs(0,0,4,4);
return 0;
}
2.
C - Til the Cows Come Home
Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.
Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.
Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input
* Line 1: Two integers: T and N
* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
Output
* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
Sample Input
5 5 1 2 20 2 3 30 3 4 20 4 5 20 1 5 100
Sample Output
90
Hint
INPUT DETAILS:
There are five landmarks.
OUTPUT DETAILS:
Bessie can get home by following trails 4, 3, 2, and 1.
思路:用Dijkstra算法。
代码:
#include<stdio.h>
int e[2050][2050],dis[1050],book[1050];
int main()
{
int k,u,i,j,n,m,t1,t2,min,t3;
int inf=0x3f3f3f3f;
scanf("%d%d",&n,&m);
for(i=1;i<=m;i++)
for(j=1;j<=m;j++)
if(i==j)
e[i][j]=0;
else
e[i][j]=e[j][i]=inf;
for(i=1;i<=n;i++)
{
scanf("%d%d%d",&t1,&t2,&t3);
if(t3<e[t1][t2])
e[t1][t2]=e[t2][t1]=t3;
}
for(i=1;i<=m;i++)
dis[i]=e[1][i];
for(i=1;i<=m;i++)
book[i]=0;
book[1]=1;
for(i=1;i<=m-1;i++)
{
min=inf;
for(j=1;j<=m;j++)
{
if(book[j]==0&&dis[j]<min)
{
min=dis[j];
u=j;
}
}
book[u]=1;
for(k=1;k<=m;k++)
{
if(e[u][k]<inf)
{
if(dis[k]>dis[u]+e[u][k])
dis[k]=dis[u]+e[u][k];
}
}
}
printf("%d\n",dis[m]);
return 0;
}
3.
最短路径 easy ver.
给出一张包含n个节点、m条边的无向图(无重边,无自环),请你求出图上两点s,t间的最短路径长度。
其中1<=n<=500,1<=m<=10000,1<=任意边权<=500000;
Input
第一行两个数n,m,分别表示节点数和边数,以空格隔开; 之后m行,每行3个数u,v,w[i],表示点u和v间有一条权值为w[i]的边; 最后一行,两个数s,t表示选择的两个点,以空格隔开。
Output
输出一个数,表示s,t间最短路径的长度。
Sample Input
4 3 1 2 6 1 3 4 2 4 2 3 4
Sample Output
12
思路:Floyd-Warshall算法。
代码:
#include<stdio.h>
int e[2050][2050],dis[1050],book[1050];
int main()
{
int k,u,i,j,n,m,t1,t2,min,t3,p,q;
int inf=0x3f3f3f3f;
scanf("%d%d",&n,&m);
for(i=1;i<=n;i++)
for(j=1;j<=n;j++)
if(i==j)
e[i][j]=0;
else
e[i][j]=e[j][i]=inf;
for(i=1;i<=m;i++)
{
scanf("%d%d%d",&t1,&t2,&t3);
e[t1][t2]=e[t2][t1]=t3;
}
for(k=1;k<=n;k++)
for(i=1;i<=n;i++)
for(j=1;j<=n;j++)
if(e[i][j]>e[i][k]+e[k][j])
e[i][j]=e[i][k]+e[k][j];
scanf("%d%d",&p,&q);
printf("%d\n",e[p][q]);
return 0;
}