Uva - 1339 - Ancient Cipher

Ancient Roman empire had a strong government system with various departments, including a secret service department. Important documents were sent between provinces and the capital in encrypted form to prevent eavesdropping. The most popular ciphers in those times were so called substitution cipher and permutation cipher. Substitution cipher changes all occurrences of each letter to some other letter. Substitutes for all letters must be different. For some letters substitute letter may coincide with the original letter. For example, applying substitution cipher that changes all letters from `A' to `Y' to the next ones in the alphabet, and changes `Z' to `A', to the message ``VICTORIOUS'' one gets the message ``WJDUPSJPVT''. Permutation cipher applies some permutation to the letters of the message. For example, applying the permutation$ \langle$2, 1, 5, 4, 3, 7, 6, 10, 9, 8$ \rangle$ to the message ``VICTORIOUS'' one gets the message ``IVOTCIRSUO''. It was quickly noticed that being applied separately, both substitution cipher and permutation cipher were rather weak. But when being combined, they were strong enough for those times. Thus, the most important messages were first encrypted using substitution cipher, and then the result was encrypted using permutation cipher. Encrypting the message ``VICTORIOUS'' with the combination of the ciphers described above one gets the message ``JWPUDJSTVP''. Archeologists have recently found the message engraved on a stone plate. At the first glance it seemed completely meaningless, so it was suggested that the message was encrypted with some substitution and permutation ciphers. They have conjectured the possible text of the original message that was encrypted, and now they want to check their conjecture. They need a computer program to do it, so you have to write one.

Input 

Input file contains several test cases. Each of them consists of two lines. The first line contains the message engraved on the plate. Before encrypting, all spaces and punctuation marks were removed, so the encrypted message contains only capital letters of the English alphabet. The second line contains the original message that is conjectured to be encrypted in the message on the first line. It also contains only capital letters of the English alphabet. The lengths of both lines of the input file are equal and do not exceed 100.

Output 

For each test case, print one output line. Output ` YES ' if the message on the first line of the input file could be the result of encrypting the message on the second line, or ` NO ' in the other case.

Sample Input 

JWPUDJSTVP
VICTORIOUS
MAMA
ROME
HAHA
HEHE
AAA
AAA
NEERCISTHEBEST
SECRETMESSAGES

Sample Output 

YES
NO
YES
YES
NO

重点是记录每个字母出现的次数就可以了

AC代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cctype>
#include <cstring>
#include <algorithm>

using namespace std;

char a[110], b[110];
int pa[26], pb[26];

int cmp(const void *a, const void *b)
{
	return *(int *)a - *(int *)b;
}

int main()
{
	while (cin >> a >> b) {
		memset(pa, 0, sizeof(pa));
		memset(pb, 0, sizeof(pb));
		int al = strlen(a);
		int bl = strlen(b);
		if (al != bl) {
			cout << "NO" << endl;
			continue;
		}
		for (int i = 0; i < al; i++) {
			pa[a[i] - 'A']++;
			pb[b[i] - 'A']++;
		}
		qsort(pa, 26, sizeof(pa[0]), cmp);
		qsort(pb, 26, sizeof(pb[0]), cmp);
		if (!memcmp(pa, pb, sizeof(pa))) {
			cout << "YES" << endl;
		}
		else {
			cout << "NO" << endl;
		}
	}

	return 0;
}



查看cipher-text通常需要以下步骤: 首先,了解cipher-text的定义。Cipher-text是一种经过加密处理的文本或数据,它无法被普通人直接阅读或理解。 其次,确定所使用的加密算法。常见的加密算法有对称加密算法和非对称加密算法。对称加密算法使用相同的密钥进行加密和解密,而非对称加密算法使用一对密钥,公钥用于加密,私钥用于解密。 对于对称加密算法,查看cipher-text的方法为:获取正确的密钥,使用相同的加密算法对cipher-text进行解密。只有使用正确的密钥,才能还原出原始的明文信息。 对于非对称加密算法,查看cipher-text的方法为:获取对应的私钥,使用私钥对cipher-text进行解密。由于非对称加密算法的特点是公钥加密、私钥解密,因此只有使用正确的私钥,才能解密出原始的明文信息。 在实际应用中,cipher-text的查看通常需要通过相关加密工具或编程语言进行操作。这些工具和语言提供了相应的解密功能接口,可以方便地查看cipher-text。 值得注意的是,对于较为复杂的加密算法和密钥长度,即使获取了正确的密钥或私钥,也不一定能够在可接受的时间范围内解密cipher-text。因此,在实际应用中,保护密钥的安全性至关重要,只有合法的使用者才能够拥有正确的密钥,并且应该限制对cipher-text的访问权限,以确保数据的安全性。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值