Uva - 11059 - Maximum Product

Given a sequence of integers S = {S1, S2, ..., Sn}, you should determine what is the value of the maximum positive product involving consecutive terms of S. If you cannot find a positive sequence, you should consider 0 as the value of the maximum product.

Input

Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si is an integer such that -10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each element in the sequence. There is a blank line after each test case. The input is terminated by end of file (EOF).

Output

For each test case you must print the message: Case #M: The maximum product is P., where M is the number of the test case, starting from 1, and P is the value of the maximum product. After each test case you must print a blank line.

Sample Input

3
2 4 -3

5
2 5 -1 2 -1

Sample Output

Case #1: The maximum product is 8.

Case #2: The maximum product is 20.

二重循环遍历过去就搞定了,因为每个数绝对值不超过10,不超过18个数,最大乘积不会超过10的18次方,这样就可以把乘积用long long存放。

不知道为什么用printf打印结果不管怎么弄都是WA,都快疯了,最后用了cout却AC了,真是各种无语。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cctype>
#include <cstring>
#include <string>
#include <sstream>
#include <vector>
#include <set>
#include <map>
#include <algorithm>
#include <stack>
#include <queue>
#include <bitset> 
#include <cassert> 

using namespace std;

int s[20];

int main()
{
	ios::sync_with_stdio(false);
	int n;
	int kase = 0;
	while (cin >> n && n) {
		for (int i = 0; i < n; i++) {
			cin >> s[i];
		}
		long long pro = 0;
		for (int star = 0; star < n; star++) {
			long long proTem = 1;
			for (int end = star; end < n; end++) {
				proTem = proTem * (long long)s[end];
				if (proTem > pro) {
					pro = proTem;
				}
			}
		}
		//printf("Case #%d: The maximum product is %d.\n\n", ++kase, pro);
		cout << "Case #" << ++kase << ": The maximum product is " << pro << ".\n\n";
	}

	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值