二分起步---Can you find it?

Can you find it?

Problem Description

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.

Input

There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.

Output

For each case, firstly you have to print the case number as the form “Case d:”, then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print “YES”, otherwise print “NO”.

Sample Input

3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10

Sample Output

Case 1:
NO
YES
NO

这是一个基础的二分,只要将Ai+Bi=X-Ci,在Ai+Bi产生的结果里二分查找X-Ci就可以了。
AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int f[500*500+1],a[505],b[505],c[505];
int len;
void init()
{
    memset(a,0,sizeof(a));
    memset(b,0,sizeof(b));
    memset(c,0,sizeof(c));
    memset(f,0,sizeof(f));
}
bool check(int k)
{
    if(k==f[lower_bound(f,f+len,k)-f])
        return true;
    else
        return false;
}
int main()
{
    int L,N,M;
    int cas=1;
    while(cin>>L>>N>>M)
    {
        init();
        for(int i=0;i<L;i++)
            cin>>a[i];
        for(int i=0;i<N;i++)
            cin>>b[i];
        int k=0;
        for(int i=0;i<L;i++)
            for(int j=0;j<N;j++)
                 f[k++]=a[i]+b[j];
        sort(f,f+k);
        len=k;
        for(int i=0;i<M;i++)
            cin>>c[i];
        int T;
        cin>>T;
        cout<<"Case "<<cas++<<":"<<endl;
        while(T--)
        {
            int x;
            cin>>x;
            int flag=0;
            for(int i=0;i<M;i++)
            {
                if(check(x-c[i]))
                {
                    flag=1;
                    break;
                }
            }
            if(flag)
                cout<<"YES"<<endl;
            else
                cout<<"NO"<<endl;
        }
    }
    return 0;
}

要开始突破二分了。
—–2017.11.11

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值