HDU - 2141 Can you find it?

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
Input There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
Output For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10
Sample Output
 

Case 1: NO YES NO


题意:给你三个长度分别为L,M,N的数组,让你从这三个数组中各选一个数,相加是否等于K,若能找到相加等于K的三个数,输出"YES",否则输出"NO"。

思路:暴力肯定会超时,先将前两个数组的数两两相加存起来,再按从小到大的顺序排序,循环遍历第三个数组,二分前两个数组相加所得的数组。
代码参考:
#include <iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<queue>
#include<stack>
#include<cstring>
#define max(a,b) a>b?a:b
#define ll long long
#define inf 0x3f3f3f3f
#define pi acos(-1.0)

using namespace std;
ll a[510];
ll b[510];
ll c[510];
ll d[510*510];
ll L,N,M;
int main()
{
    int x=0;
    while(~scanf("%lld%lld%lld",&L,&N,&M))
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(c,0,sizeof(c));
        memset(d,0,sizeof(d));
        int p=0;
        for(int i=0;i<L;i++)
            scanf("%lld",&a[i]);
        for(int i=0;i<N;i++)
            scanf("%lld",&b[i]);
        for(int i=0;i<M;i++)
            scanf("%lld",&c[i]);
        for(int i=0;i<L;i++)
        {
            for(int j=0;j<N;j++)
            {
                d[p++]=a[i]+b[j];
            }
        }
        sort(d,d+p);
        int t;
        scanf("%d",&t);
        printf("Case %d:\n",++x);
        while(t--)
        {
            ll k,ju,f=0;
            scanf("%lld",&k);
            for(int i=0;i<M;i++)
            {
                f=0;
                ju=k-c[i];
                ll le=0,r=p,mid=(le+r)/2;
                while(le<r)
                {
                    if(d[mid]<ju) le=mid+1;
                    else if(d[mid]>ju) r=mid;
                    else break;
                    mid=(le+r)/2;
                }
                if(d[mid]==ju)
                {
                    f=1;
                    break;
                }
            }
            if(f)
                printf("YES\n");
            else
                printf("NO\n");
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值