In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.
Input
Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).
Output
For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).
Sample input
10 4 3 0 0 0
Sample output
4 8, 9 5, 3 1, 2 6, 10, 7
where represents a space.
题意:
给出长度为N 的循环队列,一个人从1开始逆时针数数,数到k时,k出列。另外一人从N开始顺时针数数,数到M时,M出列。如果数到同一个人,则只需要他出列。利用数组,当a[i] == 0时表示第I个人出列。
#include<iostream>
#include<string>
#include<cstdio>
using namespace std;
int main(){
int n,k,m;
int a[200];
while(scanf("%d%d%d",&n,&k,&m)){
if(n == 0 && k == 0 && m == 0)
break;
int p = 0;
int q = n - 1;
int len = n;
for(int i = 0 ;i < n; i++)
{
a[i] = i + 1;
}
while(len > 0)
{
for(int i = 1; i< k; i ++)
{
p = ( p + 1) %n;
if(a[p] == 0)
i --;
}
for(int i = 1; i< m;i ++)
{
q = (q + n -1) % n;
if(a[q] == 0)
i --;
}
if(a[p])
{
printf("%3d",a[p]);
a[p] = 0;
len --;
}
if(a[q])
{
printf("%3d",a[q]);
a[q] = 0;
len --;
}
for(int i = 0; i < n ; i++)
{
p = (p + 1) % n;
if(a[p])
break;
}
for(int i = 0 ; i < n; i++)
{
q = (q + n - 1) % n;
if(a[q])
break;
}
if(len)
printf(",");
else
printf("\n");
}
}
return 0;
}