Queuing(矩阵快速幂)

Queuing

                                              Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                          Total Submission(s): 2842    Accepted Submission(s): 1305


Problem Description
Queues and Priority Queues are data structures which are known to most computer scientists. The Queue occurs often in our daily life. There are many people lined up at the lunch time. 

  Now we define that ‘f’ is short for female and ‘m’ is short for male. If the queue’s length is L, then there are 2L numbers of queues. For example, if L = 2, then they are ff, mm, fm, mf . If there exists a subqueue as fmf or fff, we call it O-queue else it is a E-queue.
Your task is to calculate the number of E-queues mod M with length L by writing a program.
 

Input
Input a length L (0 <= L <= 10 6) and M.
 

Output
Output K mod M(1 <= M <= 30) where K is the number of E-queues with length L.
 

Sample Input
  
  
3 8 4 7 4 8
 

Sample Output
  
  
6 2 1
 

Author
WhereIsHeroFrom
 

递推公式f(n)=f(n-1)+f(n-3)+f(n-4)
递推过程:
现在设长度为n
1,在最后一位加m时,前面无论是什么都满足,得f(n-1);
2,在最后一位加f时,倒数后2位无论加什么都不能满足,于是讨论倒数后3位,后3位可以加mmf,即+f(n-3),现在还有      一种情况没考虑到,那就是mff,可能前面是以f结尾,于是讨论倒数后4位,在后4位上加mmff,即+f(n-4)。
得到递推公式就可以构造矩阵了。

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
using namespace std;
struct Matrix {
    int a[10][10];
    Matrix() {
        for (int i = 0; i < 10; ++i) {
            for (int j = 0; j < 10; ++j) {
                a[i][j] = 0;
            }
        }
    }
};
int n, mod;
Matrix operator * (const Matrix& a, const Matrix& b) {
    Matrix c;
    for (int i = 0; i < 4; ++i) {
        for (int j = 0; j < 4; ++j) {
            c.a[i][j] = 0;
            for (int k = 0; k < 4; ++k) {
                c.a[i][j] += (a.a[i][k] * b.a[k][j]) % mod;
                c.a[i][j] %= mod;
            }
        }
    }
    return c;
}

Matrix operator ^ (Matrix& a, int k) {
    Matrix c;
    for (int i = 0; i < 4; ++i)
        for (int j = 0; j < 4; ++j)
            if (i == j)
                c.a[i][j] = 1;
    while (k) {
        if (k&1)
            c = c * a;
        k >>= 1;
        a = a * a;
    }
    return c;
}

int main() {
    Matrix a, b;
    b.a[0][0] = 6;
    b.a[1][0] = 4;
    b.a[2][0] = 2;
    b.a[3][0] = 1;
    a.a[0][0] = a.a[0][2] = a.a[0][3] = a.a[1][0] = a.a[2][1] = a.a[3][2] = 1;
    constexpr int ans[] = {1, 2, 4, 6};
    while (cin >> n >> mod) {
        if (n < 4) {
            cout << ans[n] % mod << endl;
        } else {
            
            Matrix c = a;
            c = c ^ (n - 3);
            c = c * b;
            cout << c.a[0][0] << endl;
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值