poj1651 Multiplication Puzzle(区间dp)

Multiplication Puzzle
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11343 Accepted: 7027

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

The goal is to take cards in such order as to minimize the total number of scored points. 

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650

Source


题意:给你一组数字,第一个和最后一个数字不可以取出去,其它任意取出去,当你要取出一个数字时,它有一个代价,这个代价就是与它相邻的两个数的乘积,求除了首位两位数字,把其他数字都取出来,它们的代价之和的最小值........

#include <iostream>
#include <string>
#include <algorithm>
#include <string.h>
using namespace std;
int dp[205][205], a[205];
int n;
int main() {
    memset(dp, 0, sizeof(dp));
    cin >> n;
    for (int i = 1; i <= n; ++i)
        cin >> a[i];
    //dp[i][j]表示区间[i, j]的最小值
    for (int i = n - 2; i >= 1; --i) {
        //初始化一下下
        dp[i][i + 2] = a[i] * a[i + 1] * a[i + 2];
        for (int j = i + 2; j <= n; ++j) {
            //也是初始化一下,随便找个中间点就行
            dp[i][j] = a[i] * a[i + 1] * a[j] + dp[i + 1][j];
            for (int k = i + 1; k <= j - 1; ++k) {
                //按照逻辑。。。dp[i, j] = dp[i, k] + a[i] * a[k] * a[j] + dp[k, j]
                dp[i][j] = min(dp[i][j], dp[i][k] + dp[k][j] + a[i] * a[k] * a[j]);
            }
        }
    }
    cout << dp[1][n] << endl;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值