USACO SECTION 3.1 Stamps

Stamps

Given a set of N stamp values (e.g., {1 cent, 3 cents}) and an upper limit K to the number of stamps that can fit on an envelope, calculate the largest unbroken list of postages from 1 cent to M cents that can be created.

For example, consider stamps whose values are limited to 1 cent and 3 cents; you can use at most 5 stamps. It's easy to see how to assemble postage of 1 through 5 cents (just use that many 1 cent stamps), and successive values aren't much harder:

  • 6 = 3 + 3
  • 7 = 3 + 3 + 1
  • 8 = 3 + 3 + 1 + 1
  • 9 = 3 + 3 + 3
  • 10 = 3 + 3 + 3 + 1
  • 11 = 3 + 3 + 3 + 1 + 1
  • 12 = 3 + 3 + 3 + 3
  • 13 = 3 + 3 + 3 + 3 + 1.

However, there is no way to make 14 cents of postage with 5 or fewer stamps of value 1 and 3 cents. Thus, for this set of two stamp values and a limit of K=5, the answer is M=13.

The most difficult test case for this problem has a time limit of 3 seconds.

PROGRAM NAME: stamps

INPUT FORMAT

Line 1:Two integers K and N. K (1 <= K <= 200) is the total number of stamps that can be used. N (1 <= N <= 50) is the number of stamp values.
Lines 2..end:N integers, 15 per line, listing all of the N stamp values, each of which will be at most 10000.

SAMPLE INPUT (file stamps.in)

5 2
1 3

OUTPUT FORMAT

Line 1:One integer, the number of contiguous postage values starting at 1 cent that can be formed using no more than K stamps from the set.

SAMPLE OUTPUT (file stamps.out)

13

 

/*
ID: conicoc1
LANG: C
TASK: stamps
*/
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

int Total,N;
int Values[50],Max;
int Stamps[10001],front; 
int count=0;

int Min(int A,int B)
{
	return A>B?B:A;
}

int main()
{
	FILE *fin,*fout;
	fin=fopen("stamps.in","r");
	fout=fopen("stamps.out","w");
	int i,j,k;
	fscanf(fin,"%d %d",&Total,&N);
	for(i=0;i<N;i++){
		fscanf(fin,"%d",&Values[i]);
		if(Values[i]>Max)
			Max=Values[i];
	};
	Stamps[0]=0;
	for(i=1;i<=Max;i++)
		Stamps[i]=201;
	
	front=0;
	while(Stamps[front%(Max+1)]<=Total){
		for(i=0;i<N;i++)
			Stamps[(front+Values[i])%(Max+1)]=Min(Stamps[front]+1,Stamps[(front+Values[i])%(Max+1)]);
		Stamps[front]=201;
		front=(front+1)%(Max+1);
		count++;
	}
	fprintf(fout,"%d\n",count-1);
	return 0;
}


 

一开始内存爆了,愤把空间疯狂压缩。。

最慢一个1.3sec

stamp[i] 表示总面值为i时,选取的数量

由于一个状态时只对后面Max有影响,且该状态一过以后都不会再使用,空间开Max+1大小就够了

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值