zoj1889------------------------------Ones

Given any integer 0 <= n <= 10000 not divisible by 2 or 5, some multiple of n is a number which in decimal notation is a sequence of 1's. How many digits are in the smallest such a multiple of n?


Sample Input

3
7
9901


Sample Output

3
6

12


题很短,但是看不懂 = =!

就是说输入一个数,假如有个i位的11111……111可以整除这个数,输出1的个数


普通的思想

sum=sum*10+1

然后用sum%x会超时


这里有个技巧sum=(sum*10+1)%x

这样每次sum就很小,意思就是直到把sum中保存的余数除完为止



代码:


#include <iostream>
using namespace std;

int main()
{
	long long sum;
	int count;
	int x;
	while(cin>>x)
	{
		count=1;
		sum=1;
		if(x==1)
			cout<<x<<endl;
		else
		{
			while(sum%x!=0)
			{
				sum=(sum*10+1)%x;
				count++;	
			}
			cout<<count<<endl;
		}	
	}	
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值