hdoj3530Subsequence【单调队列】



Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5271    Accepted Submission(s): 1739


Problem Description
There is a sequence of integers. Your task is to find the longest subsequence that satisfies the following condition: the difference between the maximum element and the minimum element of the subsequence is no smaller than m and no larger than k.
 

Input
There are multiple test cases.
For each test case, the first line has three integers, n, m and k. n is the length of the sequence and is in the range [1, 100000]. m and k are in the range [0, 1000000]. The second line has n integers, which are all in the range [0, 1000000].
Proceed to the end of file.
 

Output
For each test case, print the length of the subsequence on a single line.
 

Sample Input
      
      
5 0 0 1 1 1 1 1 5 0 3 1 2 3 4 5
 

Sample Output
      
      
5 4
 

题意:在一个队列中求一个最长子序列使得该子序列满足最大值与最小值的差大于k小于m求该子序列的最大长度

分别设两个单调队列非别为递增递减求最长长度即可没做单调队列之前以为神秘看了之后还挺好理解的

单调队列:http://blog.csdn.net/justmeh/article/details/5844650

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
const int maxn=100010;
int a[maxn];
int que1[maxn];//单调递减队列 
int que2[maxn];//单调递增队列 
int MAX(int a,int b){
	return a>b?a:b;
}
int MIN(int a,int b){
	return a<b?a:b;
}
int main()
{
	int n,k,m,i,j,ans,now;
	int front1,rear1,front2,rear2;
	while(scanf("%d%d%d",&n,&m,&k)!=EOF){
		front1=rear1=front2=rear2=0;ans=0;now=1;
		for(i=1;i<=n;++i){
			scanf("%d",&a[i]);
			while(front1<rear1&&a[que1[rear1-1]]<a[i])rear1--;//插入队尾 
			while(front2<rear2&&a[que2[rear2-1]]>a[i])rear2--;
			que1[rear1++]=i;que2[rear2++]=i;
			while(front1<rear1&&front2<rear2&&a[que1[front1]]-a[que2[front2]]>k){//删除队首 
				if(que1[front1]<que2[front2])now=que1[front1++]+1;
				else now=que2[front2++]+1;
			}
			if(front1<rear1&&front2<rear2&&a[que1[front1]]-a[que2[front2]]>=m){
				if(ans<i-now+1)ans=i-now+1;
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值