hdoj5428The Factor【分解质因数】

The Factor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2011    Accepted Submission(s): 590


Problem Description
There is a sequence of  n  positive integers. Fancycoder is addicted to learn their product, but this product may be extremely huge! However, it is lucky that FancyCoder only needs to find out one factor of this huge product: the smallest factor that contains more than 2 factors(including itself; i.e. 4 has 3 factors so that it is a qualified factor). You need to find it out and print it. As we know, there may be none of such factors; in this occasion, please print -1 instead. 
 

Input
The first line contains one integer  T (1T15) , which represents the number of testcases. 

For each testcase, there are two lines:

1. The first line contains one integer denoting the value of  n (1n100) .

2. The second line contains  n  integers  a1,,an (1a1,,an2×109) , which denote these  n  positive integers. 
 

Output
Print  T  answers in  T  lines.
 

Sample Input
  
  
2 3 1 2 3 5 6 6 6 6 6
 

Sample Output
  
  
6 4
 

Source

求出每个数的所有质因数中最小的两个相乘即为答案如果小于两个则无解

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#define inf 0x7fffffff
using namespace std;
const int maxn=110;
long long num[maxn];
long long ans[5];
int main()
{
	int t,i,k,n;
	scanf("%d",&t);
	while(t--){
		scanf("%d",&n);
		ans[0]=ans[1]=inf;
		for(i=0;i<n;++i){
			scanf("%lld",&num[i]);
			long long j=2;
			while(j*j<=num[i]){
				while(num[i]%j==0){
					if(j<ans[1]){
						if(j<ans[0]){
							ans[1]=ans[0];
							ans[0]=j;
						}
						else ans[1]=j;
					}
					num[i]/=j;
				}
				j++;
			}
			if(num[i]>1){
				if(num[i]<ans[1]){
					if(num[i]<ans[0]){
						ans[1]=ans[0];
						ans[0]=num[i];
					}
					else ans[1]=num[i];
				}
			}
		}
		if(ans[1]!=inf){
			printf("%lld\n",ans[0]*ans[1]);
		}
		else {
			printf("-1\n");
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值