HDU 1796 How many integers can you find (lcm + 容斥)


How many integers can you find

Time Limit: 12000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5526    Accepted Submission(s): 1584

Problem Description
  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
 
Input
  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
 
Output
  For each case, output the number.
 
Sample Input
  
  
12 2 2 3
 
Sample Output
  
  
7

Source

2008 “Insigma International Cup” Zhejiang Collegiate Programming Contest - Warm Up(4)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1796

题目大意:给一个数n和一个含有m个数的集合,求[1, n-1]中可以被集合中任意一个数整除的数集大小

题目分析:还算比较裸的容斥了,有一个大坑点,集合中可能有0,如果有0的话,直接把0去掉,还可以加个小特判,如果有1的话直接输出n就行了,注意这里容斥不是把数字直接相乘,因为它们不一定互质,所以算的是数字间的最小公倍数,举个简单例子:
25 2
6 8
答案如果直接用24 / 6 + 24 / 8 - 24 / (6 * 8)得到的是7,显然答案是6,因为24没有被容斥掉,所以我们要拿两个数的最小公倍数去容斥


#include <cstdio>
#include <cstring>
#include <algorithm>
#define ll long long
using namespace std;
int a[25], b[25];
ll ans;
int n, m, cnt;

ll gcd(ll a, ll b)
{
    return b ? gcd(b, a % b) : a;  
}

ll lcm(int a, int b)
{
    return (ll) a * b / gcd(a, b);
}

void DFS(int idx, ll cur, int sgin)
{
    for(int i = idx; i < cnt; i++)
    {
        ll tmp = lcm(cur, (ll)b[i]);
        ans += (ll) sgin * (n / tmp);
        DFS(i + 1, tmp, -sgin);
    }
}

int main()
{
    while(scanf("%d %d", &n, &m) != EOF)
    {
        n --;
        cnt = 0;
        bool flag = false;
        for(int i = 0; i < m; i++)
        {
            scanf("%d", &a[i]);
            if(a[i] != 0)
                b[cnt ++] = a[i];
            if(a[i] == 1)
                flag = true;
        }
        if(flag)
        {
            printf("%d\n", n);
            continue;
        }
        sort(b, b + cnt);
        ans = 0;
        DFS(0, 1, 1);
        printf("%I64d\n", ans);
    }
}



 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值