How many integers can you find

Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
Input
There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
Output
For each case, output the number.
Sample Input
12 2
2 3
Sample Output
7

题意:给你两个数n,m第二行给你n个数a1,a2,…,an,你需要在1到n-1之中找到a1,a2…,an,的倍数,并输出有几个。
例如N=12,集合n为{2,3},则倍数为{2,3,4,6,8,9,10},输出7.

思路:利用容斥定理,将2的倍数和3的倍数分别看成两个集合,将重复的去了即可。但是当选的集合数大于一个时,要将所选的数相乘,这是不能用n直接除两个数的乘积,要用n除两个数的最小公倍数,算的才是这两个数公有的倍数的数量。

代码

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
ll n,m;
ll aa,a[15];
ll gcd(ll a,ll b)
{
	return !b?a:gcd(b,a%b);
 } 
ll lcm(ll a,ll b )
{
	return (b/gcd(a,b)*a);
}
int main()
{
	while(~scanf("%lld %lld",&n,&m))
	{
		ll k=0;
		for(ll i=0;i<m;i++)
		{
			scanf("%lld",&aa);
			if(aa!=0)
			a[k++]=aa;
		}
		ll ans=0;
		for(ll i=1;i<(1<<k);i++)
		{
			ll sum=1,cnt=0;
			for(ll j=0;j<k;j++)
			{
				if(1&(i>>j))
				{
					sum=lcm(sum,a[j]);
					cnt++;
				}
			}
			if(cnt%2==1)
			{
				ans=ans+(n-1)/sum;
			}
			else
			{
				ans=ans-(n-1)/sum;
			}
		}
		printf("%lld\n",ans);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值