BFS广度优先搜索(4)--hdu2717(poj3278)(基础题)

 Catch That Cow

                                               Time Limit:2000MS    Memory Limit:65536KB    64bit IO Format:%lld & %llu

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a pointN (0 ≤N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the pointsX- 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.


            这道题题意:直线坐标,从n走到k,给出了三种走的方式:x-1,x+1,x*2(x为当前坐标),问最少需要走多少次。
         直接套BFS:  给定初始状态跟目标状态,要求从初始状态到目标状态的最短路。 对所有状况进行一次搜索,最先找到的肯
定就是时间最少的。
 
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
int n,k;
int vis[100005];
struct node{
	int x;
	int time;
};
void Bfs(int x){
	int i;
	queue<node>q;
	memset(vis,0,sizeof(vis));
	node s,e;
	vis[x]=1;
	s.x=x;
	s.time=0;
	q.push(s);
	while(!q.empty()){
		s=q.front();
		q.pop();
		if(s.x==k)printf("%d\n",s.time);
		for(i=0;i<3;i++){
			int xx;
			if(i==0)          //三种走的方式
				xx=s.x-1;
			else if(i==1)
				xx=s.x+1;
			else xx=s.x*2;
			if(xx<0||xx>100000)continue;
			if(vis[xx])continue;
			vis[xx]=1;
			e.x=xx;
			e.time=s.time+1;
			q.push(e);
		}
	}
}
int main()
{
	while(scanf("%d %d",&n,&k)!=EOF){
		Bfs(n);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值