hdu 2141 Can you find it? 【时间优化+二分】

Can you find it?

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 16411    Accepted Submission(s): 4172

Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 
Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 
Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 
Sample Input
  
  
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 
Sample Output
  
  
Case 1: NO YES NO

这个题目数据咋一看还真不是一般变态,1000*500*500*log(500)的算法与1000*500*500*500基本没啥区别,这样肯定TLE。

怎么办?

办法肯定是有的,为什么会超呢?

不就是要对A,B,C三个数组进行1000次询问吗?我要频繁地对这个A,B,C数组进行访问,而A,B,C数组的规模不是很大,我何不另外开一个数组来存A+B可能出现的值呢?然后只要在保存A+B的这个数组里面二分搜索Sum-C[i]的值就OK了,这样我的复杂度就只有1000*500*log(500*500)了,这样就足够保证AC了...

这个时候,我相信你肯定恍然大悟,不要看下面的代码了,还说什么,直接敲吧。

#include <cmath>
#include <cstdio>
#include <string>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 500+5;
int L,M,N,S;
int A[maxn],B[maxn],AB[maxn*maxn],C[maxn],X;
int main () {
    //freopen("input.in","r",stdin);
    int cas = 0;
    while(~scanf("%d%d%d",&L,&M,&N))
    {
        for(int i = 0;i < L;i++) scanf("%d",&A[i]);
        for(int i = 0;i < N;i++) scanf("%d",&B[i]);
        for(int i = 0;i < M;i++) scanf("%d",&C[i]);
        sort(C,C+M);

        for(int i = 0,pos = 0;i < L;i++)
            for(int j = 0;j < N;j++)
                AB[pos++] = A[i]+B[j];
        sort(AB,AB+L*N);
        int LN = unique(AB,AB+L*N) - AB;

        printf("Case %d:\n",++cas);
        scanf("%d",&S);
        for(int xx = 0;xx < S;xx++)
        {
            scanf("%d",&X);
            int sum,c,suc;
            for(int i = 0;i < M;i++)
            {
                sum = X-C[i];
                suc = binary_search(AB,AB+LN,sum);
                if(suc) break;
            }
            printf("%s\n",suc?"YES":"NO");
        }
    }
    return 0;
}

  • 4
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值