Light oj 1214 Large Division(同余定理,判断是否整除)



Description

Given two integers, a and b, you should check whethera is divisible by b or not. We know that an integera is divisible by an integer b if and only if there exists an integerc such that a = b * c.

Input

Input starts with an integer T (≤ 525), denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) andb (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case, print the case number first. Then print 'divisible' ifa is divisible by b. Otherwise print 'not divisible'.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible


这道题网上很多题解都说是同余定理推出来的结论,我也不知道为什么,上网专门搜了同余定理还是不懂,不过通过这个题还是有一个很好记并且很有用的结论的:

初始化 res为0,然后:

res=(res*10+c[i]-'0')%d
若res==0则可整除这个结论

注意 i 是从0 - n不是从n - 0;


#include<cstdio>
#include<cstring>
#include<string>
#include<iostream>
#include<sstream>
#include<algorithm>
#include<utility>
#include<vector>
#include<set>
#include<map>
#include<queue>
#include<math.h>
#include<iterator>
#include<stack>
using namespace std;
typedef long long LL;
typedef unsigned long long ULL;
const double eps=1e-8,PI=3.1415926538;
const LL MOD=1000000000+7;
const LL MAXN=4000007;

char c[301];
LL d;
LL res;
int main()
{
    int T,T1;
    scanf("%d",&T);
    T1=T;
    while(T--)
    {
        scanf("%s%lld",c,&d);
        int n=strlen(c);
        res=0;
        d=d>0?d:-d;
        for(int i=0;i<=n-1;i++)
        {
            if(c[i]=='-')continue;
            res=(res*10+c[i]-'0')%d;
        }
        res%=d;
        printf("Case %d: ",T1-T);
        if(res)printf("not divisible\n");
        else printf("divisible\n");
    }
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
要使用JavaOJ判断一个数是否为质数,可以参考以下代码: import java.util.Scanner; public class Main { public static void main(String[] args) { Scanner in = new Scanner(System.in); int x = in.nextInt(); boolean isPrime = true; if (x <= 1) { isPrime = false; } for (int i = 2; i <= Math.sqrt(x); i++) { if (x % i == 0) { isPrime = false; break; } } if (isPrime) { System.out.println("This is a prime."); } else { System.out.println("This is not a prime."); } } } 这段代码会从键盘上输入一个正整数x,然后判断x是否为质数。如果x是质数,则输出"This is a prime.",否则输出"This is not a prime."。请注意,这段代码与引用和引用中的代码非常相似,但有一些细微的差别。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *3* [Java语法练习SDUTOJ判断素数(循环结构)](https://blog.csdn.net/Cherishlife_/article/details/85223731)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] - *2* [ZZULIOJ 1057: 素数判定,Java](https://blog.csdn.net/qq_52792570/article/details/119005501)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值