8.17 E - Large Division

E- Large Division

Given twointegers, a and b, you should check whether a isdivisible by b or not. We know that an integer a isdivisible by an integer b if and only if there exists aninteger c such that a = b * c.

Input

Input starts withan integer T (≤ 525), denoting the number of test cases.

Each case startswith a line containing two integers a (-10200 ≤ a ≤ 10200) and b(|b| > 0, b fits into a 32 bit signed integer). Numbers will not containleading zeroes.

Output

For each case,print the case number first. Then print 'divisible' if a isdivisible by b. Otherwise print 'not divisible'.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible

 

题意:给出n组数据,每一组数据两个数字,判断数字a能否被数字b整除。


思路:简单的大数除小数运算,现将前一个大数用字符串读入,然后将第一个字符转化成数字对b取余数,然后将余数乘以10加上下一个数字继续对b取余数,以此类推,跑完第一个字符串,最后判断余数是否为0,为0则a能被b除尽。(貌似数据b卡int的极限值,所以计算时用long long来定义)。



#include<stdio.h>
#include<string.h>
int main()
{
	long long i,j,k,m,n,T,t,z=1,l;
	char s[1500];
	while(scanf("%d",&T)!=EOF)
	{
		while(T--)
		{
			memset(s,0,sizeof(s));
			scanf("%s%lld",s,&n);
			if(n<0)
				n=-n;
			m=0;
			l=strlen(s);
	//		printf("%d\n",l);
			if(s[0]=='-')
			{
				for(i=1;i<l;i++)
				{
					
					t=s[i]-'0';
					m=m*10+t;
					m=m%n;//printf("*m===%d\n",m);
				}
			}
			else
			{
				for(i=0;i<l;i++)
				{
					
					t=s[i]-'0';
					m=m*10+t;
					m=m%n;//printf("m===%d\n",m);
				}
			}
		//	printf("%d\n",m);
			if(m==0)
			{
				printf("Case %d: divisible\n",z++);
			}
			else
			{
				printf("Case %d: not divisible\n",z++);
			}
		}
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值