hdu 1789 Doing Homework again(贪心)

31 篇文章 0 订阅

Doing Homework again

Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.

Output
For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input
3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

Sample Output
0
3
5

思路1:
要使扣的分最少,那么应该按扣分从大到小排序,扣分相同则按截止日期从小到大排序
对每一门作业,如果在截止日期之前有空闲的天,则让其在这天完成这门作业即可,否则放到最后完成,并扣分

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

struct node
{
    int deadline,reduce;
}p[1010];
int vis[1010];

bool cmp(node a,node b)
{
    if(a.reduce==b.reduce)
        return a.deadline<b.deadline;
    return a.reduce>b.reduce;
}

int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        memset(vis,0,sizeof(vis));
        scanf("%d",&n);
        for(int i=0;i<n;++i)
            scanf("%d",&p[i].deadline);
        for(int i=0;i<n;++i)
            scanf("%d",&p[i].reduce);
        sort(p,p+n,cmp);
        int ans=0,j;
        for(int i=0;i<n;++i)
        {
            for(j=p[i].deadline;j>0;--j)
                if(!vis[j])
            {
                vis[j]=1;
                break;
            }
            if(!j)
                ans+=p[i].reduce;
        }
        printf("%d\n",ans);
    }
    return 0;
}



思路2:
按照截止日期从小到大排序,截止日期相同则按扣分从大到小排序
对于每一门作业,如果当前日期大于截止日期,说明这门作业不能按时完成,这时可以在其截止日期之前寻找扣分较小的作业来代替它,这样使得最后的扣分最少

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

struct node
{
    int x,y,flag;//flag代表这门作业是否能按时完成
} p[1010];

bool cmp(node a,node b)
{
    if(a.x==b.x)
        return a.y>b.y;
    return a.x<b.x;
}

int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0; i<n; ++i)
            scanf("%d",&p[i].x);
        for(int i=0; i<n; ++i)
            scanf("%d",&p[i].y),p[i].flag=1;
        sort(p,p+n,cmp);
        int reduced=0,day=1,tot,tmp;
        for(int i=0; i<n; ++i)
        {
            if(day>p[i].x)
            {
                tot=p[i].y,tmp=i;
                for(int j=0; p[j].x<=p[i].x&&j<i; ++j)
                {
                    if(p[j].y<tot&&p[j].flag)
                    {
                        tmp=j;
                        tot=p[j].y;
                    }
                }
                p[tmp].flag=0;
                reduced+=tot;
            }
            else
                ++day;
        }
        printf("%d\n",reduced);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值