[PAT-甲级]1010.Radix

1010. Radix (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is "yes", if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:
N1 N2 tag radix
Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set {0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number "radix" is the radix of N1 if "tag" is 1, or of N2 if "tag" is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print "Impossible". If the solution is not unique, output the smallest possible radix.

Sample Input 1:
6 110 1 10
Sample Output 1:
2
Sample Input 2:
1 ab 1 2
Sample Output 2:
Impossible

解题思路:求解N1和N2(代码中用str1和str2表示)中未知进制的那个数,并满足某个进制时和另一个在十进制下相等的条件。若存在,则输出满足条件的最小进制,否则输出Impossible。

注意:数据的存储得采用long long。得确定未知进制数的进制的取值范围(取值范围见代码中分析),即minRadix和maxRadix,利用二分查找进行查找。举例:1234,在10进制表示的大小是小于16进制的表示的大小。


#include<iostream>
#include<string>
#include<stdio.h>
using namespace std;

// 将radix进制字符串num 转成10进制的整数 
long long to_radix(string num, long long radix)
{
	long long res = 0;
	
	for(int i = 0; i < num.length(); i ++)
	{
		int x;
		if(num[i] >= '0' && num[i] <= '9')
			x = num[i] - '0';
		else
			x = num[i] - 'a' + 10;
		
		res = res * radix + x;
	}
	return res;
}

int main()
{
	// base 保存已知进制的那个数对应的十进制大小 
	// num 保存待求进制的那个数 
	string str1, str2, num;
	int tag;
	long long radix, base;
	
	cin>>str1>>str2>>tag>>radix;
	
	if(tag == 1)
	{
		num = str2; 
		base = to_radix(str1, radix);
	}
	else
	{
		num = str1;
		base = to_radix(str2, radix); 
	}
	
	// num的长度为1 
	if(num.length() == 1)
	{
		int x;
		if(num[0] >= '0' && num[0] <= '9')
			x = num[0] - '0';
		else
			x = num[0] - 'a' + 10;
		
		if(x == base)
			cout<<x+1<<endl;
		else
			cout<<"Impossible"<<endl;
		return 0;
	}
	
	// 考虑minRadix取值:minRadix肯定比num中所有数位中最大的那个加1,eg.  078最少是9进制,
	// 考虑maxRadix取值:base已经确定,所以如果此时num与base 相等,则maxRadix=base+1 
	long long minRadix = 0, maxRadix = base+1;
	for(int i = 0; i < num.length(); i ++)
	{
		int x;
		if(num[i] >= '0' && num[i] <= '9')
			x = num[i] - '0';
		else
			x = num[i] - 'a' + 10;
		
		if(x+1 > minRadix)
			minRadix = x + 1;
	}
	
	// 采用二分查找 
	while(minRadix <= maxRadix)
	{
		long long mid = (minRadix + maxRadix) / 2;
		long long x = to_radix(num, mid);
		
		if(x == base)
		{
			cout<<mid<<endl;
			return 0;
		}
		else if(x > base || x < 0)
			maxRadix = mid - 1;
		else
			minRadix = mid + 1;
	}
	cout<<"Impossible"<<endl;
	
	return 0; 
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值