PAT-甲级-1010 Radix (25 分)

60 篇文章 0 订阅
20 篇文章 0 订阅

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N​1​​ and N​2​​, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:


N1 N2 tag radix

Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number radix is the radix of N1 if tag is 1, or of N2 if tag is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix.

Sample Input 1:

6 110 1 10

Sample Output 1:

2

Sample Input 2:

1 ab 1 2

Sample Output 2:

Impossible
#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;
#define rep(i,j,k)    for(int i=j;i<k;i++)
long long change(string s,long long r){
    long long sum=0;
    int len=s.size();
    rep(i,0,len){
        int dig = s[len-i-1];
        dig = isdigit(dig) ? dig-'0' : dig-'a'+10;
        sum += dig* pow(r,i);
    }
    return sum;
}
long long find_r(string s,long long num){
    char it = *max_element(s.begin(),s.end());
    long long low = (isdigit(it)?it-'0':it-'a'+10)+1;
    long long high = max(num,low);
    while(low <= high){
        long long mid = (low + high) / 2;
        long long t = change(s,mid);
        if(t<0 || t>num) high = mid-1;
        else if(t == num) return mid;
        else low = mid + 1;
    }
    return -1;
}
int main(){
    string sa,sb,sc,sd;
    long long a,b,r,ans;
    int t,na,nb;
    cin>>sa>>sb>>t>>r;
    sc = t==1?sa:sb;
    sd = t!=1?sa:sb;
    a = change(sc,r);
    ans = find_r(sd,a);
    if(ans == -1)   cout<<"Impossible";
    else cout<<ans;
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值