[PAT-甲级]1017.Queueing at Bank

1017. Queueing at Bank (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:
7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10
Sample Output:
8.2

解题思路:模拟题,类似于操作系统中给进程分配CPU问题,计算平均等待时候,这里需要注意的case点,全部是无效数据,即结果为0.0,首先对数据按照用户到达时间进行排序,同时去除不合理数据(即到达时间超过关门时间)。接下来就是选择窗口问题,即endTime数组起到的作用。

代码如下:

#include<stdio.h>
#include<vector>
#include<algorithm>
#define INF 0x7fffffff
using namespace std;

struct Customer
{
	int arivalTime;
	int serverTime;
};

vector<Customer> que;

int convertTime(int hour, int minute, int second)
{
	return hour * 3600 + minute * 60 + second;
}

bool cmp(Customer a, Customer b)
{
	if(a.arivalTime != b.arivalTime)
		return a.arivalTime < b.arivalTime;
}

int endTime[110];//endTime[i]保存i号窗口的当前服务客户的结束时间

int main()
{
	freopen("D://input.txt", "r", stdin);
	int n, m, totalTime;
	scanf("%d%d", &n, &m);
	
	int openTime = convertTime(8, 0, 0);
	int closeTime = convertTime(17, 0, 0);
	
	for(int i = 0; i < m; i ++)
		endTime[i] = openTime;
	
	for(int i = 0; i < n; i ++)
	{
		int h, m, s, needTime;
		scanf("%d:%d:%d %d", &h, &m, &s, &needTime);
		
		int arivalTime = convertTime(h, m, s);
		if(arivalTime > closeTime)
			continue;
		
		Customer tmp;
		tmp.arivalTime = arivalTime;
		tmp.serverTime = needTime*60;
		que.push_back(tmp);
	}
	
	sort(que.begin(), que.end(), cmp);
	
	for(int i = 0; i < que.size(); i ++)
	{
		// 为第i个客户选择最早服务结束的窗口 
		int index = -1, minEndTime = INF;
		for(int j = 0; j < m; j ++)
		{
			if(endTime[j] < minEndTime)
			{
				minEndTime = endTime[j];
				index = j;
			}	
		}
		
		// 判断第i个客户有没有等待 
		if(endTime[index] <= que[i].arivalTime)
			endTime[index] = que[i].arivalTime + que[i].serverTime;
		else
		{
			totalTime = totalTime + endTime[index] - que[i].arivalTime;
			endTime[index] += que[i].serverTime;	
		}	
	}
	
	if(que.size() == 0)
		printf("0.0\n");
	else
		printf("%.1f\n", totalTime / 60.0 / que.size());
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值