A plus B(这题有点坑)

1056 - A plus B

Time Limit:1s Memory Limit:64MByte

Submissions:990Solved:240

DESCRIPTION

Two octal number integers a, b are given, and you need calculate the result a - b in octal notation.
If the result is negative, you should use the negative sign instead of complement notation.

INPUT
The first line is an integer T(1 <= T <= 1000), indicating the number of test cases.For each case, the first and only line contains two octal integers a, b.(0 <= a, b < 2^32)
OUTPUT
Print the result, one per line, in octal notation.
SAMPLE INPUT
176 7
SAMPLE OUTPUT
67
SOLUTION
输入数据会有点大,所以单纯用%o来输入的话,就会WA,所以代码如下:
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{

    int T;
    scanf("%d",&T);
    while(T--)
    {
        long  a,b;
        scanf("%llo%llo",&a,&b);
        if(a>b)
        printf("%llo\n",a-b);
        else printf("-%llo\n",b-a);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值