浙大 PAT Advanced level 1007. Maximum Subsequence Sum

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:

10 1 4


第一次做的时候想了很久,没找到很好的方法,于是遍历一遍所有可能的取值情况(即{[i,j]:0<=i<=j<N}),然后选择合适的结果。

又回顾了一遍这个题目,发现可以用动态规划的方法来做(实际上 连续子序列的最大和问题 也算是经典的动态规划的题目了o(╯□╰)o)

多种解决此类问题的基本方法,可以参考下:http://blog.csdn.net/hcbbt/article/details/10454947


第一次的代码

/* 注意Case:3 -1 0 -2 正确的输出应该为:0 0 0 */
#include <iostream>
using namespace std;

int nums[10010];
int main()
{
	int K;
	int maxsum = -1;
	int first, last = 0, sum = 0;

	cin >> K;
	first = K;

	for (int i = 0; i != K; ++i)
	{
		cin >> nums[i];
	}

	for (int i = 0; i != K; ++i)
	{
		for (int j = i; j < K; ++j)
		{
			if (j == i)
			{
				sum = nums[i];
			}
			else
			{
				sum += nums[j];
			}
			/* 不添加下面这个if语句也可以AC, 只是添加之后速度更快*/
			/* 前面的某一部分和为负, 显然这种情况下最大连续子列不可能从i开始*/
			if (sum < 0)
			{
				break;
			} 
			
			if ((sum > maxsum) || (sum == maxsum && i < first && j < last))
			{
				maxsum = sum;
				first = i;
				last = j;
			}
		}
	}
	if (-1 == maxsum)
	{
		cout << "0 " << nums[0] << ' ' << nums[K-1] << endl;
	}
	else
	{
		cout << maxsum << ' ' << nums[first] << ' ' << nums[last] << endl;
	}

	system("pause");
	return 0;
}

第二次的代码,用动态规划


/* 重叠子问题,sum[i] = max{sum[i-1]+a[i], a[i]}, 可以考虑用动态规划*/
#include <iostream>
#include <vector>
using namespace std;

int N;
vector<int> sequence;

int main()
{
	int posi, posj;					/* 记录最大子序列和的开始位置和结束位置*/
	int maxsum = -1;
	int total = -1;
	int startpos = 0;

	cin >> N;
	sequence.resize(N);

	for (int i = 0; i < N; ++i)
	{
		cin >> sequence[i];
		if (total+sequence[i] >= sequence[i])
		{
			total += sequence[i];
		}
		else
		{
			total = sequence[i];
			startpos = i;
		}

		if (total > maxsum)
		{
			maxsum = total;
			posi = startpos;
			posj = i;
		}
	}

	if (maxsum >= 0)
	{
		cout << maxsum << ' ' << sequence[posi] << ' ' << sequence[posj] << endl;
	}
	else
	{
		cout << 0 << ' ' << sequence[0] << ' ' << sequence[N-1] << endl;
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值