hdu 3833 YY's new problem

YY's new problem

Time Limit: 12000/4000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 4061    Accepted Submission(s): 1143


Problem Description
Given a permutation P of 1 to N, YY wants to know whether there exists such three elements P[i1], P[i2], P[i3] that
P[i1]-P[i2]=P[i2]-P[i3], 1<=i1<i2<i3<=N.
 

Input
The first line is T(T<=60), representing the total test cases.
Each test case comes two lines, the former one is N, 3<=N<=10000, the latter is a permutation of 1 to N.
 

Output
For each test case, just output 'Y' if such i1, i2, i3 can be found, else 'N'.
 

Sample Input
  
  
2 3 1 3 2 4 3 2 4 1
 

Sample Output
  
  
N Y
 

哈希表基础题:

#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;
#define M 10003
int hash[M];
int main ()
{
	int t,n,m,i,j;
	int flag;
	scanf("%d",&t);
	while(t--)
	{   
		flag=0;
		memset(hash,0,sizeof(hash));
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			scanf("%d",&m);
			hash[m]=1; 
			if(flag==0)
			{
				for(j=1;j<m&&j<=n-m;j++)  // 写成 m-j>0 && m+j<=n 就易懂了。这样才能保证下面使用hash数组时不越界。
				{
					if(hash[m-j]+hash[m+j]==1)    // 两者只出现过一个
					{
						flag=1;
						break;
					}
				}
			}
		}
		if(flag) printf("Y\n");
		else printf("N\n");
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值