贪心算法1之1016

1 题目编号:1016  problemQ

2 题目内容:

Problem Description
FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less. 

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
 

Input
* Line 1: A single integer N <br> <br>* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
 

Output
* Line 1: A single integer that is the median milk output.
 

Sample Input
  
  
5 2 4 1 3 5
 

Sample Output
  
  
3


3 解题思路形成过程:此题为简单的求中位数运算,用普通的排序算法即可,即可以使用双for循环。

4 感想:此题我在做时有一个疑惑,即milk output 并没有给出具体的范围,所以对于数组的长度也不好确定,只能自己估量着确定一个模糊的范围进行测试。

5 代码:

#include<iostream>
#include<stdlib.h>
using namespace std;
int main()
{
int iNum;
int iOutput[100010];
cin >> iNum;
for (int i = 0; i < iNum; i++)
{
cin >> iOutput[i];
}
for (int j = 0; j < iNum; j++)
{
for (int k = j + 1; k < iNum; k++)
{
if (iOutput[j]>iOutput[k])
{
int temp;
temp = iOutput[j];
iOutput[j] = iOutput[k];
iOutput[k] = temp;
}
}
}
cout << iOutput[(iNum - 1) / 2] << endl;
return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值