UVa1225 Digit Counting

Description

Download as PDF

Trung is bored with his mathematics homeworks. He takes a piece of chalk and starts writing a sequence of consecutive integers starting with 1 to N (1 < N < 10000) . After that, he counts the number of times each digit (0 to 9) appears in the sequence. For example, with N = 13, the sequence is:

12345678910111213

In this sequence, 0 appears once, 1 appears 6 times, 2 appears 2 times, 3 appears 3 times, and each digit from 4 to 9 appears once. After playing for a while, Trung gets bored again. He now wants to write a program to do this for him. Your task is to help him with writing this program.

Input 

The input file consists of several data sets. The first line of the input file contains the number of data sets which is a positive integer and is not bigger than 20. The following lines describe the data sets.

For each test case, there is one single line containing the number N .

Output 

For each test case, write sequentially in one line the number of digit 0, 1,...9 separated by a space.

Sample Input 

2 
3 
13

Sample Output 

0 1 1 1 0 0 0 0 0 0 
1 6 2 2 1 1 1 1 1 1

代码如下:

#include<stdio.h>
#include<string.h>

char c[45000];
int a[10];

int main()
{
    //freopen("uva1225.txt","r",stdin);
    memset(c,'\0',sizeof(c));
    for(int i=1;i<10000;i++) //把1-9999输入到字符数组c
    {
        int ls=strlen(c);
        sprintf(c+ls,"%d",i);
    }

    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        memset(a,0,sizeof(a));

        int flag=0;  //flag为数字n在数组c中的下标
        if(n>999)
            flag=2889+4*(n-1000+1);  //9+2*90+3*900*(n-1000+1)
        else if(n>99)
            flag=189+3*(n-100+1);  //9+2*90+3*(n-100+1)
        else if(n>9)
            flag=9+2*(n-10+1);
        else flag=n;

        for(int i=0;i<flag;i++) //计算1-9数字出现的个数
            a[c[i]-'0']++;

        for(int i=0;i<10;i++)
            {
                if(i==0)
                    printf("%d",a[i]);
                else printf(" %d",a[i]);
            }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值